Bug 201488 - vte.pc contains RPATH related LDFLAGS
vte.pc contains RPATH related LDFLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-06 01:56 EDT by Yijun Yuan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-24 01:22:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yijun Yuan 2006-08-06 01:56:47 EDT
Description of problem:
vte.pc contains RPATH related LDFLAGS so some other packages depends on
vte-devel won't build due to check-rpath error.

Version-Release number of selected component (if applicable):
0.13.5-1.fc6

How reproducible:
every time

Steps to Reproduce:
1.run "pkg-config --libs vte"
2.
3.
  
Actual results:
-Wl,--rpath -Wl,/usr/include -L/usr/include -L/lib -lvte -lncurses -lXft
-lgtk-x11-2.0 -lpangoxft-1.0 -lpangox-1.0 -lXrender -lfontconfig -lfreetype
-lX11 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lcairo
-lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0  


Expected results:
don't include -Wl,--rpath -Wl,/usr/include -L/usr/include
Comment 1 Behdad Esfahbod 2006-08-09 01:52:04 EDT
No idea where the rpath is coming from.
Comment 2 Kevin Fenzi 2007-03-24 01:22:23 EDT
This no longer seems to be happening on fc6 or current devel. 

I'm going to close this. If you still see the problem, feel free to re-open or
file a new bug. 

Note You need to log in before you can comment on or make changes to this bug.