Bug 2014883 - None of the grafana dashboard shows ethernet statistics for VMs [NEEDINFO]
Summary: None of the grafana dashboard shows ethernet statistics for VMs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 4.4.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.4.10
: ---
Assignee: Aviv Litman
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-17 16:53 UTC by Abhishekh Patil
Modified: 2022-02-08 10:05 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-dwh-4.4.10
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-08 10:04:44 UTC
oVirt Team: Metrics
Target Upstream Version:
alitman: needinfo? (abpatil)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHV-43820 0 None None None 2021-10-17 16:55:12 UTC
Red Hat Product Errata RHBA-2022:0461 0 None None None 2022-02-08 10:05:02 UTC
oVirt gerrit 117649 0 master MERGED Fix vm interface queries 2021-12-21 10:33:37 UTC
oVirt gerrit 118127 0 ovirt-engine-dwh-4.4 MERGED Fix vm interface queries 2021-12-22 10:59:10 UTC

Description Abhishekh Patil 2021-10-17 16:53:26 UTC
Description of problem:

None of the grafana dashboard shows ethernet statistics  for VMs. Every VM ethernet related dashboard shows 'No data'. 

Version-Release number of selected component (if applicable):
ovirt-engine-dwh-4.4.8-1.el8ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Login to Grafana and check any VM ethernet related dashboards


Actual results:

Every VM ethernet related dashboard shows 'No data'. 

Expected results:

Every VM ethernet related dashboard should show correct data


Additional info:

Comment 26 Klaas Demter 2022-01-20 19:38:55 UTC
I can confirm ethernet statistics are now shown in ovirt-engine 4.4.10 for VMs that previously didn't show any

Comment 27 Pavel Novotny 2022-01-25 17:13:54 UTC
Verified in
ovirt-engine-4.4.10.4-0.1.el8ev.noarch
ovirt-engine-dwh-4.4.10-1.el8ev.noarch

I checked all ethernet-related panels in the dashboards mentioned in comment 19 (also copy&pasted below).
All panels are showing relevant NIC data. 


1. Virtual Machine Dashboard:
- Ethernet Interface Inventory
- Ethernet Interface Tx and Rx Rates (over time)
- Ethernet Interface Tx and Rx Dropped Packets (over time)

2. Virtual Machines Trend Dashboard:
- Top 3 Most Utilized Ethernet Interface Tx and Rx Rates (over time)
- Top 3 Ethernet Interface Tx and Rx Dropped Packets (over time)

3. Virtual Machines Resource Usage Dashboard
- Top 3 Most Utilized Ethernet Interfaces - Transmit Rate
- Top 3 Most Utilized Ethernet Interfaces - Receive Rate

Comment 31 errata-xmlrpc 2022-02-08 10:04:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (RHV Manager (ovirt-engine) [ovirt-4.4.10]), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0461


Note You need to log in before you can comment on or make changes to this bug.