Bug 20150 - Compiling KDE apps fails at linking
Summary: Compiling KDE apps fails at linking
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-01 16:38 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-01 16:38:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-01 16:38:25 UTC
Whenever I run _any_ configure script or RPM build for KDE I get the same error when it checks for "KDE libraries installed":

configure: error: your system fails at linking a small KDE application!
Check, if your compiler is installed correctly and if you have used the same compiler to compil Qt and kdelibs as you did use now.

I have qt-devel-2.2.0-0.5.beta2, qt-2.2.0-5.beta2, qt1x-1.45-11, and qt1x-devel-1.45-11.  

*Note* I received this same error with Red Hat 6.2 as well.

Comment 1 Bernhard Rosenkraenzer 2000-11-01 18:38:00 UTC
If you're trying to compile a KDE 1.x application, use "konfigure" instead of "./configure" as mentioned in the release notes - it sets some variables so the old Qt will be used.

If you're trying to compile a KDE 2.0 application, update your Qt. You need Qt 2.2.1.


Note You need to log in before you can comment on or make changes to this bug.