Bug 201501 - /desktop/gnome/interface/gtk_key_theme is being ignored
/desktop/gnome/interface/gtk_key_theme is being ignored
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gconf-editor (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-06 11:15 EDT by Jes Sorensen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 06:07:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2006-08-06 11:15:08 EDT
Description of problem:

Hi,

Installed FC6 rawhide since it's the only thing that will install directly
on this Mac Mini. However, it looks like changes made in gconf-editor to
/desktop/gnome/interface/gtk_key_theme are now being ignored (unlike in FC5)
so when I set it to Emacs, I still get the broken keybindings which render
most apps impossible to use.

Ie. even after making this change, ALT-f still opens up the "File" menu
instead of jumping one word forward on the command line as it is supposed to.

Can we please have this absolutely vital feature brought back in!

Thank you,
Jes


Version-Release number of selected component (if applicable):

Fedora Core 6 - rawhide (August 6, 2006)

How reproducible:

Set /desktop/gnome/interface/gtk_key_theme to Emacs, try any app,
including gnome-terminal and hit ALT-f

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jes Sorensen 2006-08-07 12:22:04 EDT
Looks like this can be disabled under Edit->Keyboard Shortcuts, but the BugZilla
is still valid since Firefox and other apps don't respect the theme setting.
And gnome-terminal should do so automatically too.

Jes
Comment 2 Matthias Clasen 2006-08-12 01:40:25 EDT
alt-f works fine here with the Emacs key theme and e.g. gedit. 
Comment 3 Jes Sorensen 2006-08-13 06:07:56 EDT
Strange, I did a yum update and now even xchat seems to work with it ....
firefox still doesn't respect it, but thats passable.

Closing again - sorry for the noise.

Jes

Note You need to log in before you can comment on or make changes to this bug.