Bug 201524 - sumo's need to be rebuilt with xemacs-21.5
sumo's need to be rebuilt with xemacs-21.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xemacs-sumo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 01:20 EDT by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 20060510-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 12:49:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-08-07 01:20:34 EDT
Description of problem:
The current xemacs-sumo packages were built with xemacs-21.4
and some core functions/variable have changed from 21.4 to 21.5
which affects some of the sumo packages, eg those using defun-maybe.

Steps to Reproduce:
1. Look at .elc file headers
  
Actual results:
Note compiled with XEmacs 21.4

Expected results:
Should be compiled with 21.5.
Comment 1 Ville Skyttä 2006-08-07 02:35:58 EDT
Yep, I intend to do that well before FC6.  However, building them with an
earlier version is what we've always done in upstream XEmacs packages (they're
built with 21.4), and things should be compatible, even if a bit bloaty for
newer XEmacsen.  Do you know of a case where this causes actual problems with
the current sumos?
Comment 2 Jens Petersen 2006-08-07 04:26:07 EDT
Yes it prevents ddskk from working since string-char-list is not defined.
Comment 3 Jens Petersen 2006-08-07 04:27:00 EDT
That should be string-to-char-list, which is no longer in mule-utils
apparrently iirc.
Comment 4 Ville Skyttä 2006-08-07 15:42:23 EDT
Point taken, but ddskk is not in the sumos.  Anyway, functions disappearing
without deprecation period is usually a bug, I'll send a patch upstream. 
string-to-list is what one should be using instead of string-to-char-list in
XEmacs 21.5, and it works with 21.4 too.  Perhaps ddskk upstream would be
interested in that?
Comment 5 Jens Petersen 2006-09-26 04:49:42 EDT
Ok, string-to-list is defined in obsolete.el?

Anyway thanks, I add a patch to ddskk to use string-to-list.

However ddskk doesn't seem to build due to a unmatched parentheses
error when generating autoloads from skk-tankan.el.
Comment 6 Ville Skyttä 2006-09-26 12:49:46 EDT
(In reply to comment #5)
> Ok, string-to-list is defined in obsolete.el?

In 21.4 yes, in 21.5 it has moved to subr.el - but nevertheless, it's available
in both 21.[45] core XEmacs.  And FWIW, string-to-char-list will be available
again in the next 21.5 version, it's already in upstream CVS.

> However ddskk doesn't seem to build due to a unmatched parentheses
> error when generating autoloads from skk-tankan.el.

Hm, I didn't see that when I just built the latest ddskk from CVS's devel
branch.  However, the build failed due to an unrelated error in my setup which
is at the moment stricter than the FE buildsys (checks buildroot traces), this
looks like something you may want too look into:

+ /usr/lib/rpm/check-buildroot
/var/tmp/ddskk-12.2.0-root/usr/share/xemacs/mule-packages/lisp/skk/skk-setup.el:(defvar
skk-tut-file
"/var/tmp/ddskk-12.2.0-root/usr/share/xemacs/mule-packages/etc/skk/SKK.tut")
/var/tmp/ddskk-12.2.0-root/usr/share/emacs/site-lisp/ddskk/skk-setup.el:(defvar
skk-tut-file "/var/tmp/ddskk-12.2.0-root/usr/share/skk/SKK.tut")
Found '/var/tmp/ddskk-12.2.0-root' in installed files; aborting

Anyway, the packages that supersede the sumos have been really built from
sources with 21.5 now, so I suppose this bug is now taken care of.

Note You need to log in before you can comment on or make changes to this bug.