Bug 2015259 - Neofetch now requires catimg, which isn't packaged for EPEL
Summary: Neofetch now requires catimg, which isn't packaged for EPEL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: neofetch
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kees de Jong
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2015545 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-18 18:29 UTC by Steven Rosenberg
Modified: 2021-10-25 15:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-25 15:26:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Steven Rosenberg 2021-10-18 18:29:27 UTC
Description of problem:

The latest version of neofetch requires catimg, which isn't in EPEL. This is keeping the package from updating in yum.

Version-Release number of selected component (if applicable):

neofetch-7.1.0-6.el8

How reproducible:

Try to update or install neofetch

Steps to Reproduce:

1. If neofetch is already installed:

$ sudo yum upgrade

2. If neofetch isn't installed:

$ sudo yum install neofetch

Actual results:

This is the output:

Error: 
 Problem: cannot install the best update candidate for package neofetch-7.1.0-1.el8.noarch
  - nothing provides catimg needed by neofetch-7.1.0-6.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Expected results:

The package installs or updates

Additional info:

This bug can be fixed by packaging catimg for EPEL

Comment 1 Kees de Jong 2021-10-19 07:10:27 UTC
Thanks for the headsup. I also noticed this and already requested an EPEL8 branch: https://src.fedoraproject.org/rpms/catimg
Waiting for the approval. Then I'll submit an EPEL8 build for catimg.

Strange that `fedpkg build` didn't run into this problem... It will be fixed ASAP.

Comment 2 Fedora Update System 2021-10-19 07:37:55 UTC
FEDORA-EPEL-2021-d0b8de2e73 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-d0b8de2e73

Comment 3 Kees de Jong 2021-10-19 13:52:03 UTC
*** Bug 2015545 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2021-10-19 16:17:37 UTC
FEDORA-EPEL-2021-d0b8de2e73 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-d0b8de2e73

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-10-25 15:26:26 UTC
FEDORA-EPEL-2021-d0b8de2e73 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.