Bug 201527 - It displays "Draft (1)" when there is no message in Draft folder
It displays "Draft (1)" when there is no message in Draft folder
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Desktop, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 02:01 EDT by Xiaohong Wang
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 11:00:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (40.56 KB, image/png)
2006-08-07 02:01 EDT, Xiaohong Wang
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 488298 None None None Never

  None (edit)
Description Xiaohong Wang 2006-08-07 02:01:32 EDT
Description of problem:


Version-Release number of selected component (if applicable):
evolution-2.7.4-4

How reproducible:
always

Steps to Reproduce:
1. Launch Mail-Evolution and create a new Mail Message
2. Click "Save Draft" on Toolbar and Close the "Compose Message" Window 
3. Click "Drafts" under "On This Computer" and "Junk" this draft message
4. Check "Drafts" and "Junk" folders
  
Actual results:
The message is saved in "Junk" folder, but "Drafts" folder displays "Drafts (1)"

Expected results:
When there is no messeage saved in Draft, it should be "Draft" instead of "Draft
(1)"

Additional info:
Comment 1 Xiaohong Wang 2006-08-07 02:01:36 EDT
Created attachment 133714 [details]
screenshot
Comment 2 Matthew Barnes 2006-08-11 13:23:57 EDT
Can you plese upgrade to evolution-2.7.91 and try this one again?  I'm having a
hard time reproducing the bug on the latest Rawhide release.

The saved draft is immediately marked as read, so I never see the Drafts (1).
Comment 3 Michal Babej 2006-11-03 07:19:25 EST
Hello,

I have a similar issue with Evolution-2.8.0-7.fc6 : When i receive two emails,
mark them as read, folder becomes INBOX from INBOX(2). Then i shut down
Evolution, on the next launch the folder is bold INBOX(2) again, but when i
click it, it immediately becomes normal INBOX. This occures even after sync with
mail server.
Comment 4 Christopher Aillon 2007-04-17 15:25:38 EDT
Is there a test server we can use which has this problem?  We are unable to
reproduce here....
Comment 5 Matthew Barnes 2007-10-02 15:21:46 EDT
Is this problem still present on Fedora 8 Test 2 or later?
Comment 6 Matthew Barnes 2007-10-02 15:22:13 EDT
Oops... didn't mean to close this.
Comment 7 Milan Crha 2007-10-19 11:02:36 EDT
I can reproduce this with draft folder, so this part I moved upstream. [1]

The second part, Michal's, I cannot reproduce, even I noticed this occasionally.
From my point of view: evolution stores states of folders somewhere, this state
is not stored every time the change is done, so if one closes evolution before
it is saved, then after new start you see state like before, which is fine
because new resync will fix it. But, when folder is synced before restoring
saved state, then it can remain in previous/wrong state. Just a guess. BTW, I'm
sure, there is other bug for this issue.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=488298
Comment 8 Matthew Barnes 2008-01-18 11:01:29 EST
Upstream bug is fixed in Rawhide and Michal's issue is no longer reproducible
for me either (possibly fixed).  Feel free to reopen if you see either of these
problems again.
Comment 9 Matthew Barnes 2008-01-18 11:05:54 EST
Oops, didn't mean to change the resolution.

Note You need to log in before you can comment on or make changes to this bug.