Bug 2015282 - Please package PyDrive2 to fix bug with duplicity/deja dup
Summary: Please package PyDrive2 to fix bug with duplicity/deja dup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PyDrive
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Nick Bebout
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1882028 (view as bug list)
Depends On: 2017490
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-18 19:40 UTC by Marty Wesley
Modified: 2021-11-28 01:09 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-21 01:55:06 UTC
Type: Bug


Attachments (Terms of Use)
first draft for spec file (1.56 KB, text/x-matlab)
2021-10-25 16:34 UTC, Patrick C. F. Ernzer
mteixeira: review?
Details

Description Marty Wesley 2021-10-18 19:40:01 UTC
Description of problem: PyDrive has a known occasional bug related to duplicity/deja dup backup to Google drive and the handling of redirects. PyDrive2 fixes this problem. The duplicity/deja dup code base already tries to use PyDrive2 before falling back to PyDrive, so packaging PyDrive2 in Fedora will fix the duplicity/deja dup bug.


Version-Release number of selected component (if applicable):

PyDrive2 1.10.0

https://github.com/iterative/PyDrive2/releases

Comment 1 Matthew Miller 2021-10-25 16:03:57 UTC
*** Bug 1882028 has been marked as a duplicate of this bug. ***

Comment 2 Patrick C. F. Ernzer 2021-10-25 16:34:17 UTC
Created attachment 1836933 [details]
first draft for spec file

Please note; I am a consultant, not a developer.
This is the spec file I quickly put together for myself as I prefer packages over pip install and have to use deja-dup to save to GDrive

Comment 3 Mauricio Teixeira 2021-10-25 17:39:41 UTC
Comment on attachment 1836933 [details]
first draft for spec file

I don't have a RHEL box available, but I tried to build this in Fedora 34 and it fails because the version of the python3-google-api-client package is 1.6.7, while the spec lists 1.12.5. Is that an actual requirement, or simply an artifact of the system where the spec was created?

Comment 5 Mikel Olasagasti Uranga 2021-10-25 21:53:25 UTC
I created a copr repo with PyDrive2 and a couple of required dependencies:

https://copr.fedorainfracloud.org/coprs/mikelo2/PyDrive2/

Also created PRs for required deps:

https://src.fedoraproject.org/rpms/google-auth-httplib2/pull-request/1
https://src.fedoraproject.org/rpms/google-api-python-client/pull-request/3

Once deps are ready I'll work to get PyDrive2 in Fedora te replace PyDrive.

Comment 6 Mauricio Teixeira 2021-10-26 01:12:51 UTC
On an initial/quick test, Mikel's package seems to be working.

Comment 7 Eric Lavarde 2021-10-26 11:24:45 UTC
Works for me as well, Fedora 34. I did a backup and restore exercise of my whole home directory. Well done!

I would perhaps only complain about the camel case of the package name and ask if it could be put in small caps (even though I know that's the way it is currently) because I think that having all package names in small caps facilitate things.

Comment 8 Patrick C. F. Ernzer 2021-10-28 12:54:08 UTC
(In reply to Mauricio Teixeira from comment #3)
> Comment on attachment 1836933 [details]
[...]
> it fails because the version of the python3-google-api-client package is
> 1.6.7, while the spec lists 1.12.5.

yeah I rebuilt python3-google-api-client as well because I was under the impression it was needed. No longer 100% sure now.

> Is that an actual requirement, or simply an artifact of the system where the spec was created?

Normally I'd double check PyDrive2 now for requirements, but since Mikel made a copr available I suggest we concentrate on those pkgs.
I'll rip out my 3 self built ones now and plug in the copr. I'll report back if anything were to break for me but since we already have positive reports I do not expect that to happen.

Comment 9 Patrick C. F. Ernzer 2021-11-17 10:14:18 UTC
Comment on attachment 1836933 [details]
first draft for spec file

since I am a consultant, not a dev, I'm pretty sure I should not be flagged as reviewer,
clearing flag.

Comment 10 Mikel Olasagasti Uranga 2021-11-17 10:23:55 UTC
Hi Patrick,

PyDrive2 is available for Fedora rawhide already:

https://src.fedoraproject.org/rpms/PyDrive2

deja-dup on rawhide already depends on PyDrive2.

There is a plan to backport it to Fedora 35 (and maybe 34), but because of dependencies it is taking some time to coordinate with other Fedora contributors. You can check the plan here:

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/YFTZW73PYPCTQZAO5LMMVMUGXZGT4TZ5/

Meanwhile you can check my copr repo on https://bugzilla.redhat.com/show_bug.cgi?id=2015282#c5 and install PyDrive2 from there.

I hope everything will be fixed by next week.

Comment 11 Eric Lavarde 2021-11-18 07:27:05 UTC
After upgrade, the copr works as well like a charm under F35. Happy to hear about the backport though, it'll make it easier to use.

For sake of completeness:

```
$ rpm -qa | grep -i -e pydrive -e dup -e google-api-client
python3-google-api-client-2.27.0-1.fc35.noarch
python3-PyDrive-1.3.1-18.fc35.noarch
duplicity-0.8.20-3.fc35.x86_64
deja-dup-42.8-1.fc35.x86_64
duply-2.3.1-2.fc35.noarch
python3-PyDrive2-1.10.0-1.fc35.noarch
```

Comment 12 Fedora Update System 2021-11-19 19:16:57 UTC
FEDORA-2021-4bbfcae462 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4bbfcae462

Comment 13 Fedora Update System 2021-11-19 19:56:51 UTC
FEDORA-2021-ed754a04da has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ed754a04da

Comment 14 Fedora Update System 2021-11-20 02:05:45 UTC
FEDORA-2021-ed754a04da has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ed754a04da`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ed754a04da

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2021-11-20 02:20:07 UTC
FEDORA-2021-4bbfcae462 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4bbfcae462`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4bbfcae462

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Mikel Olasagasti Uranga 2021-11-20 10:48:42 UTC
For those of you that used my COPR, in order to have a clean install:

ALL: sudo dnf remove -y python3-PyDrive2

F34: sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ed754a04da
     sudo dnf reinstall python3-google-auth-httplib2 --enablerepo=updates-testing --advisory=FEDORA-2021-ed754a04da

F35: sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4bbfcae462
     sudo dnf reinstall python3-google-auth-httplib2 --enablerepo=updates-testing --advisory=FEDORA-2021-4bbfcae462 

ALL: sudo dnf remove -y python3-PyDrive

Basically remove PyDrive2 from copr, install new deja-dup version that depends on PyDrive2, substitute python3-google-auth-httplib2 using Fedora's release and remove old PyDrive.

If you don't remove python3-PyDrive2 as first step or python3-google-auth-httplib2 at the end don't worry, the copr and Fedora versions are equal.

Once tested remember to give karma so we can push this faster to stable:

F35: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4bbfcae462
F34: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ed754a04da

Comment 17 Fedora Update System 2021-11-21 01:55:06 UTC
FEDORA-2021-4bbfcae462 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2021-11-28 01:09:37 UTC
FEDORA-2021-ed754a04da has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.