Bug 201532 - Cannot rebuild pwlib from source rpm
Cannot rebuild pwlib from source rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pwlib (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 03:23 EDT by Jan "Yenya" Kasprzak
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 16:47:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2006-08-07 03:23:03 EDT
Description of problem:
On my system (Fedora Core 5), the pwlib library cannot be rebuilt, rpmbuild
complains about unpackaged but installed files.

Version-Release number of selected component (if applicable):
pwlib-1.10.1-5.src.rpm

How reproducible:
100%

Steps to Reproduce:
1. rpbuild --rebuild pwlib-1.10.1-5.src.rpm
  
Actual results:
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/pwlib-root
error: Installed (but unpackaged) file(s) found:
   /usr/lib64/pwlib/devices/videoinput/dc_pwplugin.so

Expected results:
pwlib x86_64 rpm and pwlib-devel.x86_64.rpm should be built.

Additional info:
Adding
%{_libdir}/pwlib/devices/videoinput/dc_pwplugin.so
to the %files section of the spec file, and then rebuilding from the spec file
fixes the problem. It is probably because I have the libdc1394-devel package
installed (so maybe adding a BuildPrereq would be appropriate as well).
Comment 1 Daniel Veillard 2007-06-20 16:47:52 EDT
we build with 
libdv-devel libraw1394-devel libavc1394-devel
but not with libdc1394-devel which is not part of the core distribution,
at least in Fedora Core 5 and 6. It's not in Fedora 7 Everything so 
I think that's normal pwlib is not compiled against it.
So I think it's not a bug, if you really want to add the dependancy to
Fedora please follow the guidelines to get a new package in, and then
please create a new report for the latest version,

  thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.