Bug 2015491 - Install/Remove buttons are cropped, the text is off-screen
Summary: Install/Remove buttons are cropped, the text is off-screen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-discover
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Depends On:
Blocks: F35FinalBlocker F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-10-19 10:47 UTC by Kamil Páral
Modified: 2021-10-21 23:17 UTC (History)
7 users (show)

Fixed In Version: plasma-discover-5.23.0-3.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-21 23:17:49 UTC
Type: Bug


Attachments (Terms of Use)
apps tab (153.75 KB, image/png)
2021-10-19 10:48 UTC, Kamil Páral
no flags Details
featured tab (142.49 KB, image/png)
2021-10-19 10:48 UTC, Kamil Páral
no flags Details
installed tab (85.35 KB, image/png)
2021-10-19 10:48 UTC, Kamil Páral
no flags Details
search results (96.73 KB, image/png)
2021-10-19 10:49 UTC, Kamil Páral
no flags Details
rpm -qa (61.40 KB, text/plain)
2021-10-19 10:49 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2021-10-19 10:47:56 UTC
Description of problem:
If I run plasma-discover, I see the button labels cropped off-screen. See screenshots.

In the past, I sometimes saw the buttons properly. So this could be some race, or it depends on the system environment somehow.

Increasing the desktop resolution (and even rebooting) doesn't help, the buttons still look the same.

I can also see this problem just by starting Discover on the KDE Live image, no installation.

Version-Release number of selected component (if applicable):
plasma-discover-5.23.0-2.fc35.x86_64
qt5-qtdeclarative-5.15.2-8.fc35.x86_64
appstream-0.14.6-1.fc35.x86_64

How reproducible:
right now always, but not always in the past

Steps to Reproduce:
1. boot KDE Live image (e.g. Fedora-KDE-Live-x86_64-35-20211018.n.0.iso) and start plasma-discover
2. look at the buttons

Comment 1 Kamil Páral 2021-10-19 10:48:48 UTC
Created attachment 1834586 [details]
apps tab

Comment 2 Kamil Páral 2021-10-19 10:48:53 UTC
Created attachment 1834587 [details]
featured tab

Comment 3 Kamil Páral 2021-10-19 10:48:57 UTC
Created attachment 1834588 [details]
installed tab

Comment 4 Kamil Páral 2021-10-19 10:49:02 UTC
Created attachment 1834589 [details]
search results

Comment 5 Kamil Páral 2021-10-19 10:49:07 UTC
Created attachment 1834590 [details]
rpm -qa

Comment 6 Kamil Páral 2021-10-19 10:50:29 UTC
I wonder if it happens for other people as well, or just for me. Proposing for a blocker discussion. The users might be smart enough to guess what the button says, or we might want to block F35 on this.

Comment 7 Kamil Páral 2021-10-19 14:51:22 UTC
I burned Fedora-KDE-Live-x86_64-35-20211018.n.0.iso to an usb stick and tested on bare metal, just booting the live system and running Discover. I see the same problem even on bare metal.

Comment 8 Adam Williamson 2021-10-19 15:27:22 UTC
That's odd, I didn't see it in any of my testing yesterday...what locale is in use? Does it matter?

Comment 9 Adam Williamson 2021-10-19 15:38:36 UTC
Huh. Just tried booting a live image and running Discover right away, and I did see this. But I'm pretty sure it wasn't happening yesterday. That's odd. I wonder if it's affected by available package metadata somehow?

Comment 10 Aleix Pol 2021-10-19 16:15:57 UTC
https://invent.kde.org/-/snippets/1913/raw < this addressed it for me.

This is happening probably because you're using Discover against an older version of KF5.

Comment 11 Kamil Páral 2021-10-19 16:19:16 UTC
I tried switching locales, and saw it in all of them. But in the past few days, I saw it just sometimes and couldn't pinpoint what caused it. Today I saw it in each boot, so I reported it.

Comment 12 Adam Williamson 2021-10-19 16:48:31 UTC
I'm running a scratch build with Aleix's proposed patch (and an attempt to force a cache refresh for #2011322)...

Comment 13 Fedora Update System 2021-10-19 23:09:24 UTC
FEDORA-2021-1949dabf93 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1949dabf93

Comment 14 Kamil Páral 2021-10-20 06:32:37 UTC
(In reply to Fedora Update System from comment #13)
> FEDORA-2021-1949dabf93 has been submitted as an update to Fedora 35.
> https://bodhi.fedoraproject.org/updates/FEDORA-2021-1949dabf93

Fixes the buttons.

Comment 15 Adam Williamson 2021-10-20 16:41:33 UTC
+4 for FE (counting anyone in favour of blocker as also in favour of FE) at https://pagure.io/fedora-qa/blocker-review/issue/556 , marking accepted FE. Note this was in RC1 already (I snuck it in with the fix for 2011322).

Comment 16 Geraldo Simião 2021-10-21 00:43:10 UTC
(In reply to Kamil Páral from comment #14)
> (In reply to Fedora Update System from comment #13)
> > FEDORA-2021-1949dabf93 has been submitted as an update to Fedora 35.
> > https://bodhi.fedoraproject.org/updates/FEDORA-2021-1949dabf93
> 
> Fixes the buttons.

Confirmed here too

Comment 17 Ben Cotton 2021-10-21 18:38:43 UTC
In today's Go/No-Go meeting, we agreed: This is fixed, but for paperwork purposes, it violates the package manager functionality requirements
https://meetbot.fedoraproject.org/fedora-meeting/2021-10-21/f35-final-go_no_go-meeting.2021-10-21-17.00.log.html#l-397

Comment 18 Fedora Update System 2021-10-21 23:17:49 UTC
FEDORA-2021-1949dabf93 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.