Bug 201570 - secmark patch for iptables
secmark patch for iptables
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
rawhide
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 201573 205514
  Show dependency treegraph
 
Reported: 2006-08-07 11:05 EDT by Karl MacMillan
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-02 08:04:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add secmark to iptables package (19.07 KB, patch)
2006-08-07 11:05 EDT, Karl MacMillan
no flags Details | Diff

  None (edit)
Description Karl MacMillan 2006-08-07 11:05:51 EDT
Description of problem:

Iptables lacks the necessary patches to enable secmark. Secmark is a new network
labeling scheme for SELinux that is a priority for RHEL 5 / FC6. Most of the
work is complete:

1) Kernel portion is accepted upstream and included in rawhide kernels
2) Iptables patches are accepted upstream (can be found in iptables svn)

The latest iptables release (1.3.5) does _not_ include the necessary patches, so
the only work remaining is to include a simple backport in the rawhide packages.

I have attached a patch that is rebased to apply cleanly on top of the other
iptables patches in the current iptables rpm.

More information can be found at http://people.redhat.com/jmorris/selinux/secmark/.

Version-Release number of selected component (if applicable):
1.3.5 of iptables
Comment 1 Karl MacMillan 2006-08-07 11:05:57 EDT
Created attachment 133740 [details]
Patch to add secmark to iptables package
Comment 2 Thomas Woerner 2006-08-28 11:08:28 EDT
Please have a look at #201570.
Comment 3 Thomas Woerner 2006-08-28 11:08:58 EDT
Please have a look at #201573.
Comment 4 Daniel Walsh 2006-08-28 12:53:04 EDT
We need this patch.
Comment 5 Thomas Woerner 2007-08-02 08:03:27 EDT
secmark is supported in iptables since package iptables-1.3.5-2.

Note You need to log in before you can comment on or make changes to this bug.