Bug 20159 - fsav (linux) virus message when printing
fsav (linux) virus message when printing
Status: CLOSED DUPLICATE of bug 18081
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-01 15:22 EST by David Warden
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-01 15:28:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the file I was testing with. Any text file with 8 char first line would do it. (67 bytes, patch)
2000-11-01 15:27 EST, David Warden
no flags Details | Diff

  None (edit)
Description David Warden 2000-11-01 15:22:55 EST
I installed 7.0 Deluxe Workstation on a Compaq ML370 server.  The server is
running Samba, xinetd, telnet server, ftp server and apache.  The printers
involved are HP LJ 4000 and Okidata 320.  They are connected via a HP
Jetdirect but I can reproduce this problem with the printers attached
directly to the server. 

I noticed that when certain files were printing via lpr the following would
print on the page:
"No way to print this type of input file: fsav (linux) virus (8224-11-13)" 
The numbers have been different also (25903-35),(29811-116),(29538-102). 
After copying the file to different directories, performing chmod and chown
with no success I was able to find something.

If I lpr'd printcap it would print fine but the file that I was using would
print the above message.  I altered my file and realized that if the first
line contained exactly 8 characters then I would get this message.  If I
changed the number of characters by more or less than 8 it would print
fine.  I added a comment of exactly 8 characters on the first line of
printcap  and then tried to print and I would get the above message.  If I
created a new file with just an 8 character line then it would print just
part of the above message "No way to print this type of input file:"  If
the file contained additional lines then it would print the full message.

Everything else prints fine to these printers so far.  The server has been
running for about 3 days with 11 people accessing it.  This was a
replacement for their Novell server.  The Samba jobs print fine. Netscape
on the server itself prints fine and the ascii test in Printtool prints
fine.

Thanks for any help - David.
Comment 1 David Warden 2000-11-01 15:27:58 EST
Created attachment 4874 [details]
This is the file I was testing with.  Any text file with 8 char first line would do it.
Comment 2 Tim Waugh 2000-11-02 04:40:30 EST
See bug 18081.

The work-around is to edit your /usr/share/magic file and remove (or put '#'
signs in front of) these lines (lines 1833-1856):

#------------------------------------------------------------------------------
# fsav:  file(1) magic for datafellows fsav virus definition files
# Anthon van der Neut (anthon@mnt.org)
0       beshort         0x1575          fsav (linux) macro virus
>8      leshort         >0              (%d-
>11     byte            >0              \b%02d-
>10     byte            >0              \b%02d)

8       byte            0x0a
>12     byte            0x07
>11     leshort         >0              fsav (linux) virus (%d-
>10     byte            0               \b01-
>10     byte            1               \b02-
>10     byte            2               \b03-
>10     byte            3               \b04-
>10     byte            4               \b05-
>10     byte            5               \b06-
>10     byte            6               \b07-
>10     byte            7               \b08-
>10     byte            8               \b08-
>10     byte            9               \b10-
>10     byte            10              \b11-
>10     byte            11              \b12-
>9      byte            >0              \b%02d)


*** This bug has been marked as a duplicate of 18081 ***

Note You need to log in before you can comment on or make changes to this bug.