Bug 2015914 - GNOME Classic session uses X11 instead of Wayland
Summary: GNOME Classic session uses X11 instead of Wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: gnome-shell-extensions
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Martin Krajnak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-20 10:38 UTC by Neal Gompa
Modified: 2022-05-17 12:47 UTC (History)
8 users (show)

Fixed In Version: gnome-shell-extensions-40.4-5.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-17 12:32:42 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-100362 0 None None None 2021-10-20 13:26:19 UTC
Red Hat Product Errata RHBA-2022:2340 0 None None None 2022-05-17 12:32:49 UTC

Description Neal Gompa 2021-10-20 10:38:46 UTC
This bug was initially created as a copy of Bug #2015741

Description of problem:
The GNOME Classic session is only available as an X11 session, even though it's compatible with Wayland. There's no technical reason that this should only be available through X11, given that the difference between the main and classic session is running the same program with an environment variable that starts in "classic mode".

Version-Release number of selected component (if applicable):
40.4-2.el9

How reproducible:
Always

Steps to Reproduce:
1. Install CentOS Stream 9
2. Login with "GNOME Classic"

Actual results:
GNOME Classic is started as an X11 session.

Expected results:
GNOME Classic is started as a Wayland session.

Additional information:
There's an upstream fix for this: https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/195

Comment 2 Ray Strode [halfline] 2021-10-20 13:25:41 UTC
See bug 1595825 for where we added a wayland classic session for rhel 8.

Comment 5 Martin Krajnak 2021-11-03 13:49:17 UTC
gnome-classic-session-40.4-5.el9.noarch
gnome-shell-extension-common-40.4-5.el9.noarch


Login screen has two options for Classic Gnome Classic and Gnome Classic on Xorg.
Option Gnome Classic started classic session under wayland for me:

WAYLAND_DISPLAY=wayland-0
XDG_SESSION_TYPE=wayland
XAUTHORITY=/run/user/1000/.mutter-Xwaylandauth.KBDNC1

Comment 7 errata-xmlrpc 2022-05-17 12:32:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (new packages: gnome-shell-extensions), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:2340


Note You need to log in before you can comment on or make changes to this bug.