Bug 2016176 - kube-storage-version-migrator constantly reporting type "Upgradeable" status Unknown
Summary: kube-storage-version-migrator constantly reporting type "Upgradeable" status ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-storage-version-migrator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.9.z
Assignee: Luis Sanchez
QA Contact: Rahul Gangwar
URL:
Whiteboard: tag-ci LifecycleReset
Depends On: 1928141
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-20 20:45 UTC by Luis Sanchez
Modified: 2021-11-01 13:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1928141
Environment:
Last Closed: 2021-11-01 13:44:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-storage-version-migrator-operator pull 72 0 None open [release-4.9] Bug 2016176: kube-storage-version-migrator constantly reporting type "Upgradeable" status Unknown 2021-10-21 12:01:33 UTC
Red Hat Product Errata RHBA-2021:4005 0 None None None 2021-11-01 13:44:51 UTC

Comment 1 W. Trevor King 2021-10-20 21:13:52 UTC
4.9 has already shipped, so aim for 4.9.z.  And not a regression since 4.9.0 (the current behavior is old code), so blocker-.

Comment 4 Rahul Gangwar 2021-10-26 06:20:08 UTC
oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.9.0-0.nightly-2021-10-25-231142   True        False         11m     Cluster version is 4.9.0-0.nightly-2021-10-25-231142

oc get clusteroperators | grep kube-storage
kube-storage-version-migrator              4.9.0-0.nightly-2021-10-25-231142   True        False         False      37m     

oc describe co/kube-storage-version-migrator | grep -B 3 Upgradeable
    Message:               All is well
    Reason:                AsExpected
    Status:                True
    Type:                  Upgradeable

Comment 10 errata-xmlrpc 2021-11-01 13:44:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4005


Note You need to log in before you can comment on or make changes to this bug.