Bug 2016275 - github.com can not be resolved inside pods where cluster is running on openstack.
Summary: github.com can not be resolved inside pods where cluster is running on openst...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.8
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.8.z
Assignee: Miheer Salunke
QA Contact: Shudi Li
URL:
Whiteboard:
Depends On: 2009210
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-21 07:32 UTC by OpenShift BugZilla Robot
Modified: 2022-08-04 22:39 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-02 14:42:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 2807 0 None open [release-4.8] Bug 2016275: [on-prem] Set coredns bufsize to 512 2021-10-26 08:52:13 UTC
Red Hat Product Errata RHBA-2021:4020 0 None None None 2021-11-02 14:42:13 UTC

Comment 1 Miciah Dashiel Butler Masters 2021-10-26 16:05:03 UTC
This is a severe issue but not a regression, so setting blocker-.

Comment 5 Shudi Li 2021-10-28 03:22:36 UTC
Verified it with 4.8.0-0.nightly-2021-10-27-154740 on IPI on OpenStack and passed.

1.
% oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.8.0-0.nightly-2021-10-27-154740   True        False         13m     Cluster version is 4.8.0-0.nightly-2021-10-27-154740
%

2.check bufsize in all the nodes, which is 512 as expected.
% oc debug node/shudi-48-os1-lqhd9-master-0
Starting pod/shudi-48-os1-lqhd9-master-0-debug ...
To use host binaries, run `chroot /host`
Pod IP: 192.168.3.172
If you don't see a command prompt, try pressing enter.
sh-4.4# chroot /host
sh-4.4# cat /etc/coredns/Corefile
. {
    errors
    bufsize 512
    health :18080
    forward . 10.11.142.1 {
        policy sequential
    }
    cache 30
    reload
...<-----snip----->
sh-4.4#

3. Can carry out dns query of github.com successfully in another pod
% oc rsh centos-pod
sh-4.4# dig  github.com

; <<>> DiG 9.11.13-RedHat-9.11.13-6.el8_2.1 <<>> github.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8444
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
; COOKIE: 4a78c5694924aa22 (echoed)
;; QUESTION SECTION:
;github.com.			IN	A

;; ANSWER SECTION:
github.com.		30	IN	A	140.82.114.3

;; Query time: 5 msec
;; SERVER: 172.30.0.10#53(172.30.0.10)
;; WHEN: Thu Oct 28 03:12:09 UTC 2021
;; MSG SIZE  rcvd: 77

sh-4.4#

4. check the log from all dns pods under openshift-openstack-infra NS(Without carrying the dns query in the dns pod)
% oc -n openshift-openstack-infra logs coredns-shudi-48-os1-lqhd9-master-0 -c coredns
.:53
[INFO] plugin/reload: Running configuration MD5 = f5121b6db390e887b6cc8ced3a7db15e
CoreDNS-1.8.1
linux/amd64, go1.16.6, 
[INFO] Reloading
[INFO] plugin/reload: Running configuration MD5 = f339170bf4c691c6b5b5bd274dfd1fa3
[INFO] Reloading complete
[INFO] Reloading
[INFO] plugin/reload: Running configuration MD5 = d6f2c2274e669f419008077e91778234
[INFO] Reloading complete
%

Comment 7 errata-xmlrpc 2021-11-02 14:42:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4020


Note You need to log in before you can comment on or make changes to this bug.