Bug 201647 - aoss utility missing, bad interaction between Firefox and sound apps
aoss utility missing, bad interaction between Firefox and sound apps
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 17:58 EDT by Florin Andrei
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 14:26:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2006-08-07 17:58:15 EDT
Description of problem:
aoss is a wrapper script included in the ALSA software that makes it easier for
apps to use the ALSA OSS compat library.
Some apps, such as Firefox or, more precisely, the Flash plugin, use the OSS
interface to play sounds. Because of that, there's sometimes a conflict between
the browser and sound apps with regard to access to the sound card.
E.g., if you start a media player (such as XMMS, etc.) and after that you start
Firefox, there's no sound from those Firefox plugins (such as Flash) that have
the ability to play sound. This issue disappears if Firefox is launched via aoss
like this:

$ aoss firefox &

Please include aoss in future versions of the package, or at least in
alsa-utils. It is the only way to work around this bug.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.12-1.rc1

How reproducible:
always

Steps to Reproduce:
1. Start a media player such as XMMS and play a file
2. Start Firefox and browse to a Flash-enabled site
  
Actual results:
The Flash content has no sound.

Expected results:
Any and all Firefox plugins should play the sound regardless of whether other
media players are active at the same time.

Additional info:
According to some, the issue only shows up on systems with a sound card that
lacks hardware mixing support.
See the discussion here, thread is called "XMMS and Firefox (or Flash?) not
playing along nicely":

http://music.columbia.edu/pipermail/linux-audio-user/2006-August/thread.html#37626

The problem also shows up in older Fedora versions, such as FC5 and possibly
also FC4 and older.

Some distros such as Ubuntu not only include aoss, but provide a system-level
variable called FIREFOX_DSP which, when set to "aoss" automatically uses aoss
with Firefox (see discussion thread on the LAU mailing list linked above). This
is a great idea.
Comment 1 Florin Andrei 2006-08-07 18:08:04 EDT
Or just package aoss as a separate package named "alsa-oss" since that's where
it really belongs.
Comment 2 Martin Stransky 2006-08-08 09:02:40 EDT
Hm, And what about put it into extras?
Comment 3 Florin Andrei 2006-08-08 13:15:33 EDT
Extras is fine too IMO.
Comment 4 Rahul Sundaram 2006-08-29 14:26:49 EDT
Submit it a package for Fedora Extras then. We rather fix everything in Fedora
Core to work with ALSA.  Even flash plugin releases in the near future are going
to use this. 

Note You need to log in before you can comment on or make changes to this bug.