Bug 201650 - directory corruption in Linux 2.6.17 with xfs
directory corruption in Linux 2.6.17 with xfs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Eric Sandeen
Brian Brock
http://oss.sgi.com/projects/xfs/faq.h...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 18:49 EDT by Thomas Antony
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-11 02:18:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 6757 None None None Never

  None (edit)
Description Thomas Antony 2006-08-07 18:49:10 EDT
Description of problem:
The linux kernel 2.6.17 can cause directory corruption with xfs formatted
partitions.
In the Linux kernel 2.6.17 release a subtle bug was accidentally introduced into
the XFS directory code by some "sparse" endian annotations. This bug was
sufficiently uncommon (it only affects a certain type of format change, in Node
or B-Tree format directories, and only in certain situations).

Version-Release number of selected component (if applicable):
kernel-2.6.17-*


How reproducible:
update the kernel to a 2.6.17 version and have a xfs partiton formatted with xfs
and mounted r/w.

Steps to Reproduce:
1. format a partition with xfs
2. update to a 2.6.17 kernel
3. mount it r/w and do crreate/modifiy some data
  
Actual results:
directory corruption and data loss

Expected results:
a stable filesystem

Additional info:
http://oss.sgi.com/projects/xfs/faq.html#dir2
Comment 1 Dave Jones 2006-08-08 15:01:11 EDT
This should be fixed in the 2.6.17.8 based update currently in updates-testing
(due to move to final today/tomorrow) I think.  Eric ?
Comment 2 Eric Sandeen 2006-08-08 15:39:04 EDT
This should have been fixed in 2.6.17.7 actually.

http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.17.7

grep for "XFS: corruption fix"

Also, xfsprogs v 2.8.10 will be needed to repair the damage...
Comment 3 Thomas Antony 2006-08-10 04:21:23 EDT
I have created a bug entry against xfsprogs, but did not get a response from
Jeff Garzik yet.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=201654

Note You need to log in before you can comment on or make changes to this bug.