Bug 201654 - xfsprogs doesn't detect directory courruption with kernel version 2.6.17
xfsprogs doesn't detect directory courruption with kernel version 2.6.17
Status: CLOSED DUPLICATE of bug 205906
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Russell Cattelan
http://oss.sgi.com/projects/xfs/faq.h...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 19:12 EDT by Thomas Antony
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 16:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Antony 2006-08-07 19:12:28 EDT
Description of problem:
In the Linux kernel 2.6.17 release a subtle bug was accidentally introduced into
the XFS directory code by some "sparse" endian annotations. The result is
direcory corruption and data loss. To add insult to injury, xfs_repair(8) is
currently not correcting these directories on detection of this corrupt state
either. The xfs_check tool, or xfs_repair -n, should be able to detect any
directory corruption. Version 2.8.10 is able to detect and repair the directory
corruption.

Version-Release number of selected component (if applicable):
xfsprogs-2.7.3

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
xfs_check and xfs_repair does not detect and repair the directory corruption.

Expected results:
The xfs_check tool, or xfs_repair -n, should be able to detect any directory
corruption.

Additional info:
http://oss.sgi.com/projects/xfs/faq.html#dir2
Comment 1 Russell Cattelan 2006-09-27 16:50:44 EDT

*** This bug has been marked as a duplicate of 205906 ***

Note You need to log in before you can comment on or make changes to this bug.