Bug 201662 - gaim Accept File crash
gaim Accept File crash
Status: CLOSED DUPLICATE of bug 201791
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 20:54 EDT by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 21:47:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-08-07 20:54:46 EDT
I know this isn't a gaim problem, but filing this against myself so I remember
later to get a traceback.  Rawhide is currently too broken in deps to install
what I need.

(gdb) bt
#0  0x0079aff8 in raise () from /lib/libc.so.6
#1  0x0079c54f in abort () from /lib/libc.so.6
#2  0x00d1f1b5 in dbus_malloc () from /lib/libdbus-1.so.3
#3  0x00d09067 in dbus_watch_set_data () from /lib/libdbus-1.so.3
#4  0x00d054c1 in dbus_watch_set_data () from /lib/libdbus-1.so.3
#5  0x00cd7653 in dbus_connection_allocate_data_slot () from /lib/libdbus-1.so.3
#6  0x00cd561f in dbus_bus_get_unix_user () from /lib/libdbus-1.so.3
#7  0x00cd5a7b in dbus_bus_register () from /lib/libdbus-1.so.3
#8  0x00cd6028 in dbus_bus_register () from /lib/libdbus-1.so.3
#9  0x0472b92e in gnome_vfs_daemon_set_current_connection () from
/usr/lib/libgnomevfs-2.so.0
#10 0x04746c3a in gnome_vfs_volume_monitor_client_get_type () from
/usr/lib/libgnomevfs-2.so.0
#11 0x0022f6ba in g_type_create_instance () from /lib/libgobject-2.0.so.0
#12 0x00216f92 in g_object_set () from /lib/libgobject-2.0.so.0
#13 0x00214dfa in g_object_newv () from /lib/libgobject-2.0.so.0
#14 0x002158bf in g_object_new_valist () from /lib/libgobject-2.0.so.0
#15 0x00215a70 in g_object_new () from /lib/libgobject-2.0.so.0
#16 0x04747dda in gnome_vfs_volume_monitor_emit_pre_unmount () from
/usr/lib/libgnomevfs-2.so.0
#17 0x04747e6e in gnome_vfs_get_volume_monitor () from /usr/lib/libgnomevfs-2.so.0
#18 0x05528d5d in fs_module_create () from
/usr/lib/gtk-2.0/2.10.0/filesystems/libgnome-vfs.so
#19 0x0022f6ba in g_type_create_instance () from /lib/libgobject-2.0.so.0
#20 0x00216f92 in g_object_set () from /lib/libgobject-2.0.so.0
#21 0x00214dfa in g_object_newv () from /lib/libgobject-2.0.so.0
#22 0x002158bf in g_object_new_valist () from /lib/libgobject-2.0.so.0
#23 0x00215a70 in g_object_new () from /lib/libgobject-2.0.so.0
#24 0x055262ac in gtk_file_system_gnome_vfs_new () from
/usr/lib/gtk-2.0/2.10.0/filesystems/libgnome-vfs.so
#25 0x055262e7 in fs_module_create () from
/usr/lib/gtk-2.0/2.10.0/filesystems/libgnome-vfs.so
#26 0x00ff2cad in gtk_file_selection_set_filename () from
/usr/lib/libgtk-x11-2.0.so.0
#27 0x00ff2e33 in gtk_file_selection_set_filename () from
/usr/lib/libgtk-x11-2.0.so.0
#28 0x00fe3ac4 in gtk_file_chooser_button_new () from /usr/lib/libgtk-x11-2.0.so.0
#29 0x0021716c in g_object_set () from /lib/libgobject-2.0.so.0
#30 0x00fe73a1 in gtk_file_chooser_button_new () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x00214dfa in g_object_newv () from /lib/libgobject-2.0.so.0
#32 0x00215969 in g_object_new_valist () from /lib/libgobject-2.0.so.0
#33 0x00215a70 in g_object_new () from /lib/libgobject-2.0.so.0
#34 0x00fd9578 in gtk_file_chooser_button_new () from /usr/lib/libgtk-x11-2.0.so.0
#35 0x00feb93c in gtk_file_chooser_widget_new () from /usr/lib/libgtk-x11-2.0.so.0
#36 0x00214dfa in g_object_newv () from /lib/libgobject-2.0.so.0
Comment 1 Stu Tomlinson 2006-08-09 20:59:42 EDT
(re: http://www.j5live.com/?p=246 referenced in Bug #201791) We don't use
gnome-vfs directly, something else (!gaim) should handle this.
Comment 2 Warren Togami 2006-08-09 21:47:23 EDT

*** This bug has been marked as a duplicate of 201791 ***
Comment 3 Mark Doliner 2006-08-11 00:38:02 EDT
Stu has a very good point.  It seems like gtk or the gtk file chooser should
take care of that.

Note You need to log in before you can comment on or make changes to this bug.