Bug 201667 - docbook2pdf broken
docbook2pdf broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: docbook-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Mejzlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 22:45 EDT by Yao Zhang
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-18 10:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sgml/ contents (778 bytes, application/x-gzip)
2006-08-08 11:46 EDT, Yao Zhang
no flags Details

  None (edit)
Description Yao Zhang 2006-08-07 22:45:57 EDT
Description of problem:
docbook2pdf failed to generate pdf.

Version-Release number of selected component (if applicable):
docbook-utils-pdf-0.6.14-5.1

How reproducible:
Always.

Steps to Reproduce:
1.  Sample book.xml
-----------------------------------------------------
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
                  "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
<book>
  <bookinfo>
    <title>Book</title>
    <author><firstname>John</firstname><surname>Doe</surname></author>
    <copyright><year>1998</year><holder>John Doe</holder></copyright>
  </bookinfo>
  <chapter><title>1</title><para> ... </para></chapter>
  <chapter><title>2</title><para> ... </para></chapter>
  <chapter><title>3</title><para> ... </para></chapter>
</book>
-----------------------------------------------------

2.  Run
docbook2pdf book.xml
3.  Failed with the following errors:

-----------------------------------------------------
Using catalogs: /etc/sgml/xml-docbook-4.2-1.0-30.1.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl#print
Working on: /work/yaoz/cvs/wenxiang/doc/fda/book.xml
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:9:96:W: cannot
generate system identifier for public text "-//Norman Walsh//DOCUMENT DocBook
Print Stylesheet//EN"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:39:37:E: no
style-specification or external-specification with ID "DOCBOOK"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:496:19:E: reference
to undefined variable "$italic-seq$"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:495:17:E: reference
to undefined variable "$charseq$"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:494:17:E: reference
to undefined variable "$mono-seq$"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:493:20:E: reference
to undefined variable "$italic-mono-seq$"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:492:18:E: reference
to undefined variable "$mono-seq$"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:491:17:E: reference
to undefined variable "$bold-seq$"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:490:19:E: reference
to undefined variable "$bold-mono-seq$"
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
......
!  ==> Fatal error occurred, the output PDF file is not finished!
Transcript written on book.log.
-----------------------------------------------------

  
Actual results:
The generated book.pdf can not be opened.


Expected results:
Working book.pdf file.

Additional info:
Tried on FC1 which works.  On FC5 it also failed.
Comment 1 Tim Waugh 2006-08-08 06:48:04 EDT
Please do this:

tar zcf /tmp/sgml.tar.gz /etc/sgml

and attach the resulting /tmp/sgml.tar.gz file.

Works fine for me on a fresh devel install, so it's probably an upgrade issue.
Comment 2 Yao Zhang 2006-08-08 11:46:29 EDT
Created attachment 133798 [details]
/etc/sgml/ contents
Comment 3 Yao Zhang 2006-08-17 15:18:32 EDT
After remove docbook-style-dsssl rpm and reinstall again,
docbook2pdf works now.

Note You need to log in before you can comment on or make changes to this bug.