Bug 201713 - member failure and rgmanager transitions are not smooth
Summary: member failure and rgmanager transitions are not smooth
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-08 14:08 UTC by Lon Hohberger
Modified: 2009-04-16 22:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 21:40:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lon Hohberger 2006-08-08 14:08:37 UTC
Description of problem:

Sometimes, it takes awhile before membership transitions are processed
correctly.  This should be near-instantaneous after the event is received.


Version-Release number of selected component (if applicable): CVS/head 7-Aug-2006


How reproducible: 80-90%

Comment 1 Lon Hohberger 2006-08-08 14:12:38 UTC
This seems primarily seems to occur due to the timeouts in vft.c, and sometimes,
this causes services to be in the 'stopped' state.  It appears to be simply that
VF is trying to communicate with the no-longer-listening node, expecting a response.

There are a few possible fixes:
(a) Give up on a node if it doesn't respond
(b) Retry - after re-checking a node's listening status from CMAN
(c) Correct it so that VF doesn't get the wrong membership list (e.g. it
shouldn't try to communicate with nodes which are not listening).

Comment 2 Lon Hohberger 2006-08-09 21:40:22 UTC
Fixes in CVS

Comment 3 Nate Straz 2007-12-13 17:19:01 UTC
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.


Note You need to log in before you can comment on or make changes to this bug.