Bug 2017258 - [ovirt] install fails: due to terraform error "Cannot attach Virtual Disk: Disk is locked" on vm resource
Summary: [ovirt] install fails: due to terraform error "Cannot attach Virtual Disk: Di...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.8
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.8.z
Assignee: Gal Zaidman
QA Contact: Veronika Fuxova
URL:
Whiteboard:
Depends On: 2015811
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-26 07:23 UTC by Gal Zaidman
Modified: 2021-11-11 20:12 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2015811
Environment:
Last Closed: 2021-11-11 20:12:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 5329 0 None open Bug 2017258: bump oVirt terraform provider version which fix "Disk is locked" bug 2021-10-27 13:57:45 UTC
Red Hat Product Errata RHBA-2021:4109 0 None None None 2021-11-11 20:12:25 UTC

Comment 3 Veronika Fuxova 2021-10-29 12:31:24 UTC
RHV: 4.4.9.3-0.3.el8ev
OCP: 4.8.0-0.nightly-2021-10-28-175240

Steps: 
1) Started an installation of OCP on RHV
2) Verified that this error doesn't appear 

level=error msg=Error: failed to attach disk: Fault reason is "Operation Failed". Fault detail is "[Cannot attach Virtual Disk: Disk is locked. Please try again later.]". HTTP response code is "409". HTTP response message is "409 Conflict".
level=error
level=error msg=  on ../tmp/openshift-install-367614815/template/main.tf line 46, in resource "ovirt_vm" "tmp_import_vm":
level=error msg=  46: resource "ovirt_vm" "tmp_import_vm" {
level=error
level=error
level=fatal msg=failed to fetch Cluster: failed to generate asset "Cluster": failed to create cluster: failed to apply Terraform: failed to complete the change

3) Cancelled the installation when the installer printed "INFO Waiting up to 20m0s for the Kubernetes API at ..."
4) Repeated the process 3 times 

Expected behavior: 
No error in the installation process. 

Actual behavior: 
No error in the installation process.

Comment 6 errata-xmlrpc 2021-11-11 20:12:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.19 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4109


Note You need to log in before you can comment on or make changes to this bug.