Bug 2017497 - Failed to start Create swap on /dev/zram0 with zram-generator-1.0.1-1.fc35
Summary: Failed to start Create swap on /dev/zram0 with zram-generator-1.0.1-1.fc35
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-zram-generator
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rust SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-26 16:28 UTC by Matt Fagnani
Modified: 2021-10-29 23:10 UTC (History)
3 users (show)

Fixed In Version: rust-zram-generator-1.0.1-3.fc35
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-29 23:10:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Matt Fagnani 2021-10-26 16:28:36 UTC
Description of problem:

I ran sudo dnf offline-upgrade download (with updates-testing enabled) then sudo dnf offline-upgrade reboot in a Fedora 35 KDE Plasma installation. The update included zram-generator-1.0.1-1.fc35. On the boot after the update, I pressed Esc while the plymouth screen was shown. Errors like "Failed to start Create swap on /dev/zram0." were shown repeatedly on the screen. The journal showed errors including the following.

Oct 26 11:59:28 systemd[1]: Found device /dev/zram0.
Oct 26 11:59:28 systemd[1]: Starting Create swap on /dev/zram0...
Oct 26 11:59:28 kernel: zram0: detected capacity change from 0 to 15159296
Oct 26 11:59:28 zram-generator[689]: Error: /systemd-makefs call failed for /dev/zram0
Oct 26 11:59:28 zram-generator[689]: Caused by:
Oct 26 11:59:28 zram-generator[689]:     No such file or directory (os error 2)
Oct 26 11:59:28 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-zram-setup@zram0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Oct 26 11:59:28 systemd[1]: systemd-zram-setup@zram0.service: Main process exited, code=exited, status=1/FAILURE
Oct 26 11:59:28 systemd[1]: systemd-zram-setup@zram0.service: Failed with result 'exit-code'.
Oct 26 11:59:28 systemd[1]: Failed to start Create swap on /dev/zram0.
Oct 26 11:59:28 systemd[1]: Dependency failed for Compressed Swap on /dev/zram0.
Oct 26 11:59:28 systemd[1]: dev-zram0.swap: Job dev-zram0.swap/start failed with result 'dependency'.
...
Oct 26 11:59:28 systemd[1]: Starting Create swap on /dev/zram0...
Oct 26 11:59:28 lvm[687]:   2 logical volume(s) in volume group "fedora" now active
Oct 26 11:59:28 zram-generator[734]: Error: Failed to configure disk size into /sys/block/zram0/disksize
Oct 26 11:59:28 zram-generator[734]: Caused by:
Oct 26 11:59:28 zram-generator[734]:     Device or resource busy (os error 16)
Oct 26 11:59:28 kernel: zram: Cannot change disksize for initialized device
Oct 26 11:59:28 systemd[1]: systemd-zram-setup@zram0.service: Main process exited, code=exited, status=1/FAILURE
Oct 26 11:59:28 systemd[1]: systemd-zram-setup@zram0.service: Failed with result 'exit-code'.
Oct 26 11:59:28 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-zram-setup@zram0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Oct 26 11:59:28 systemd[1]: Failed to start Create swap on /dev/zram0.
Oct 26 11:59:28 lvm[609]:   2 logical volume(s) in volume group "fedora" monitored
Oct 26 11:59:28 systemd[1]: Dependency failed for Compressed Swap on /dev/zram0.
Oct 26 11:59:28 systemd[1]: dev-zram0.swap: Job dev-zram0.swap/start failed with result 'dependency'.

systemctl status systemd-zram-setup@zram0.service showed it failed to start.

× systemd-zram-setup@zram0.service - Create swap on /dev/zram0
     Loaded: loaded (/usr/lib/systemd/system/systemd-zram-setup@.service; static)
    Drop-In: /run/systemd/generator/systemd-zram-setup@zram0.service.d
             └─bindsto-swap.conf
     Active: failed (Result: exit-code) since Tue 2021-10-26 12:09:53 EDT; 2min 38s ago
       Docs: man:zram-generator(8)
             man:zram-generator.conf(5)
    Process: 1727 ExecStart=/usr/lib/systemd/system-generators/zram-generator --setup-device zram0 (code=exited, status=1/FAILURE)
   Main PID: 1727 (code=exited, status=1/FAILURE)
        CPU: 4ms

Oct 26 12:09:53 localhost.localdomain systemd[1]: Starting Create swap on /dev/zram0...
Oct 26 12:09:53 localhost.localdomain zram-generator[1727]: Error: Failed to configure disk size into /sys/block/zram0/disksize
Oct 26 12:09:53 localhost.localdomain zram-generator[1727]: Caused by:
Oct 26 12:09:53 localhost.localdomain zram-generator[1727]:     Device or resource busy (os error 16)
Oct 26 12:09:53 localhost.localdomain systemd[1]: systemd-zram-setup@zram0.service: Main process exited, code=exited, status=1/FAILURE
Oct 26 12:09:53 localhost.localdomain systemd[1]: systemd-zram-setup@zram0.service: Failed with result 'exit-code'.
Oct 26 12:09:53 localhost.localdomain systemd[1]: Failed to start Create swap on /dev/zram0.

Version-Release number of selected component (if applicable):
zram-generator-1.0.1-1.fc35

How reproducible:
2/2 boots

Steps to Reproduce:
1. Boot a Fedora 35 KDE Plasma installation
2. Log in to Plasma on Wayland
3. start konsole
4. update to zram-generator-1.0.1-1.fc35 which I did by
sudo dnf offline-upgrade download (with updates-testing enabled) 
sudo dnf offline-upgrade reboot
5. Reboot if needed


Actual results:
Failed to start Create swap on /dev/zram0 with zram-generator-1.0.1-1.fc35

Expected results:
swap on on /dev/zram0 would be started normally as before

Additional info:

Comment 1 Fedora Update System 2021-10-26 18:13:33 UTC
FEDORA-2021-a8034992a9 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a8034992a9

Comment 2 Fedora Update System 2021-10-26 18:13:35 UTC
FEDORA-2021-a8034992a9 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a8034992a9

Comment 3 Fedora Update System 2021-10-27 06:18:35 UTC
FEDORA-2021-82a48ba538 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-82a48ba538

Comment 4 Fedora Update System 2021-10-28 15:17:24 UTC
FEDORA-2021-82a48ba538 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-82a48ba538

Comment 5 Fedora Update System 2021-10-29 21:17:10 UTC
FEDORA-2021-82a48ba538 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-82a48ba538`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-82a48ba538

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-10-29 23:10:57 UTC
FEDORA-2021-82a48ba538 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.