This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 201752 - Missing menu entry for ksmarttray
Summary: Missing menu entry for ksmarttray
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: smart (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-08 18:22 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.42-37
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 22:30:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2006-08-08 18:22:36 UTC
ksmarttray lacks a menu entry, one can be "borrowed" from Enrico's old package
at http://ensc.de/fedora/smart-0.41-0.6.src.rpm

Comment 1 Axel Thimm 2006-08-09 09:41:12 UTC
Should a tray object really have a menu entry? I don't have one for my weather
or battery display.

Comment 2 Ville Skyttä 2006-08-09 14:52:47 UTC
If it's not available through other means (eg. KDE's "Add applet to panel..."
functionality), no doubt about it IMO.

Comment 3 Axel Thimm 2006-08-09 15:09:52 UTC
This seems like the right thing to do. Do you know how?
I'm going to raise that upstream, too.

Comment 4 Ville Skyttä 2006-08-09 15:38:49 UTC
I don't know for sure, but a bit of Googling and looking into the contents of my
hard drive makes me believe that the "add applet" stuff is available only for
DSO applets, not executables.
http://developer.kde.org/documentation/tutorials/dot/panel-applets.html#the_description_file



Comment 5 Ville Skyttä 2006-08-09 15:41:53 UTC
On the other hand, I suppose the "add applet" stuff is available only in KDE,
thus leaving other DE users who would be interested in ksmarttray because a
"native" applet is not available for their DE without a way to launch it from
the GUI.

Comment 6 Axel Thimm 2006-08-20 14:35:03 UTC
OK, I asked upstream, if no better solution is given I'll use Enrico's menuing
trick as suggested.


Comment 7 Axel Thimm 2006-08-20 15:17:10 UTC
I got some feedback (that's how SuSE seems to have solved this problem):

Does it work dropping the desktop file under one of the following dirs:

/etc/xdg/autostart  /usr/share/autostart  /usr/share/gnome/autostart

One can set a default whether ksmartray will run or not through

X-KDE-autostart-condition=ksmarttrayrc:General:Autostart:true

which can be overriden by a ksmarttrayrc managed through the KDE configuration
framework.


Comment 8 Ville Skyttä 2006-08-20 17:17:28 UTC
That sounds like an orthogonal/additional thing to me -- whether to autostart
ksmarttray or not as opposed to whether it can be launched some way in the GUI.
 I've no experience with the former, but dropping a desktop file into the dirs
mentioned in comment 7 did not seem to have any effect, and I'm not sure what
"managed through the KDE configuration framework" means in practice.

Comment 9 Axel Thimm 2006-09-01 22:30:04 UTC
Copied over ensc's solution.



Note You need to log in before you can comment on or make changes to this bug.