Bug 2017541 - systemd - tpm2 is missing
Summary: systemd - tpm2 is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: systemd
Version: CentOS Stream
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: David Tardon
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-26 18:52 UTC by lejeczek
Modified: 2022-05-17 16:28 UTC (History)
6 users (show)

Fixed In Version: systemd-250-3.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-17 15:57:34 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gitlab redhat/centos-stream/rpms systemd merge_requests 36 0 None None None 2021-11-05 11:15:58 UTC
Red Hat Issue Tracker RHELPLAN-100828 0 None None None 2021-10-26 18:53:07 UTC
Red Hat Product Errata RHBA-2022:3979 0 None None None 2022-05-17 15:57:48 UTC

Description lejeczek 2021-10-26 18:52:38 UTC
Description of problem:

-> $ systemd-cryptenroll --tpm2-device=list
TPM2 not supported on this build. 

Version-Release number of selected component (if applicable):

systemd-249-4.el9.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 David Tardon 2021-11-05 09:51:16 UTC
I don't remember any talks about disabling TPM2 support, therefore I think we just haven't noticed it's auto-disabled because its build deps are missing...

Comment 5 errata-xmlrpc 2022-05-17 15:57:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (new packages: systemd), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:3979


Note You need to log in before you can comment on or make changes to this bug.