Bug 2018129 - Kuryr controller crash looping on self._get_vip_port(loadbalancer).id 'NoneType' object has no attribute 'id'
Summary: Kuryr controller crash looping on self._get_vip_port(loadbalancer).id 'Non...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.9.z
Assignee: Michał Dulko
QA Contact: rlobillo
URL:
Whiteboard:
Depends On: 2014538
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-28 10:02 UTC by Michał Dulko
Modified: 2021-12-06 11:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2014538
Environment:
Last Closed: 2021-12-06 11:22:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 585 0 None open Bug 2018129: Ensure KLB is updated 2021-11-13 01:00:41 UTC
Red Hat Product Errata RHBA-2021:4889 0 None None None 2021-12-06 11:22:45 UTC

Comment 5 rlobillo 2021-12-01 07:30:52 UTC
Verified in 4.9.0-0.nightly-2021-11-29-233413 on top of OSP16.1 (RHOS-16.1-RHEL-8-20210903.n.0) with OVN-Octavia.

The LB creation logic has changed from: 

1. Create LB
2. Populate result with that LB
3. If there was a failure during "Create LB"
4. Find LB
5. Update KLB CRD.

to:

1. Check if LB exists, and if it does, re-use the same LB.
2. If it doesn't exist, then create new LB
3. Populate result with that LB
4. Update KLB CRD

This new logic is working as expected, as confirmed by installation and running kuryr-tempest-plugin tests (Logs attached).

It is agreed with the BZ assignee that this is enough for validating this fix, as the systematic reproduction requires code modification.

Comment 9 errata-xmlrpc 2021-12-06 11:22:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.10 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4889


Note You need to log in before you can comment on or make changes to this bug.