Bug 2018271 - fedora-release-identity-cloud says "Cloud Edition", Cloud has not been an edition for years
Summary: fedora-release-identity-cloud says "Cloud Edition", Cloud has not been an edi...
Keywords:
Status: ASSIGNED
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release
Version: rawhide
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Mohan Boddu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: BetaBlocker, F37BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-10-28 16:58 UTC by Adam Williamson
Modified: 2022-03-16 17:49 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2021-10-28 16:58:08 UTC
/usr/lib/os-release in fedora-release-identity-cloud says:

VERSION="35 (Cloud Edition)"
PRETTY_NAME="Fedora Linux 35 (Cloud Edition)"
VARIANT="Cloud Edition"

but Cloud has not been an edition for, oh, years, ever since we replaced it with Atomic (which itself isn't an Edition any more).

This is a clear violation of Final release criterion "...Release-blocking images that are not part of any edition must not identify themselves as being part of any edition." - https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria#Self-identification

Comment 1 Matthew Miller 2021-10-28 17:28:40 UTC
Yeah, um, this is probably My Fault. We should have done this for Fedora 26 but no one had "actually follow through" as a responsibility as part of the plan.

Comment 2 Ben Cotton 2021-10-28 18:03:04 UTC
In today's Go/No-Go meeting, we agreed Cloud is not currently an Edition, so it violates the "Release-blocking images that are not part of any edition must not identify themselves as being part of any edition"
https://meetbot.fedoraproject.org/fedora-meeting/2021-10-28/f35-final-go_no_go-meeting.2021-10-28-17.01.log.html#l-95

We subsequently agreed to waive this to F36 Beta under the "late blocker" exception:
https://meetbot.fedoraproject.org/fedora-meeting/2021-10-28/f35-final-go_no_go-meeting.2021-10-28-17.01.log.html#l-253

Comment 3 Matthew Miller 2021-10-28 20:31:47 UTC
For the record, here's the history of this:


When we (FESCo, the Fedora Board) worked out the Editions part of Fedora.next, we decided (primarily at Flock in Charlotte, but much discussion after) that we wanted three editions focusing on what we at the time saw as major, broad, use cases. At the time, the "Pets vs. Cattle" metaphor for cloud computing was quite in vogue. Basically, Server was to handle the carefully-curated-individual server case, Cloud the at-scale one, and Workstation to be the personal platform for people developing and running those. See  https://fedoramagazine.org/fedora-present-and-future-a-fedora-next-2014-update-part-ii-whats-happening/ and in particular the section "Is three a magic number?"

Also from around that time, https://fedoramagazine.org/fedora-present-and-future-a-fedora-next-2014-update-part-iv-e-fedora-cloud/


> Josh spoke about the Fedora Workstation product being, in some ways, the most difficult, and my first comment about Fedora Cloud is to joke that it’s the easiest, because we start with the minimal base “and then we’re done!”
> 
> But, really, the idea of Fedora Cloud is to see what we can provide beyond that. At DevConf, I mentioned that we were exploring the idea of integrating ostree, and since then, we have agreed and are in (sometimes frantic) progress towards making that one of our key features in Fedora 21. I also talked about a Docker host image as an out-of-the-box sort of solution (a pre-assembled Lego set, if you remember back to Part II of this series). We’ve decided to combine these two things in conjunction with the upstream Project Atomic. That project provides the plans and best practices for running containerized applications, including configuration and orchestration, and Fedora (along with RHEL and CentOS) will provide the actual implementation.


... so this was really _always_ the plan. It just went on a kind of strange journey along the way.

At the time of the transition, the Cloud WG _as a separate entity_ was basically defunct. There are some Cloud WG meetings from the time, but the focus is on Atomic, and the ticket landed in the Atomic WG tracker: https://pagure.io/atomic-wg/issue/158. This might seem a little weird procedural, but there was not a Cloud group separate from the Atomic group.

After we made that decision, there were enough people (and particularly, Dusty Mabe's heroic work) interested in keeping Fedora Cloud Base Image building and released that we indeed kept doing it. In the years after, we decided, officially, at least twice, to merge Fedora Server and Fedora Cloud (because _both_ groups were basically just one or two overworked people), but never actually did the work of making that happen (same reason, really). See https://lists.fedoraproject.org/archives/list/cloud@lists.fedoraproject.org/message/QZEGCWFGLRQ7HMW2E2JCKLFGWGN34EQZ/ for one (short) thread about this.


HOWEVER, ALL OF THIS IS JUST HISTORICAL CONTEXT. I'm not making an argument, just reviewing how we got here.

I don't think it necessarily determines whether we should have a Cloud Edition _now_. We certainly have an active Cloud WG, and an active Server WG. That's cool, and way better than the place we were at before. I don't want to break that.

I guess I also don't want to overload this bug, so I'm going to stop here and continue the discussion on Fedora Discussion. I'll link that in a comment following this one.

Comment 4 Matthew Miller 2021-10-28 21:31:41 UTC
See https://discussion.fedoraproject.org/t/fedora-cloud-edition-not-an-edition-and-the-future/34064?u=mattdm, which expands (greatly) on the above comment.

Comment 5 Adam Williamson 2022-01-13 21:55:22 UTC
So, can we please do something about this now? Ideally *before* 36 Beta? thanks.

Comment 6 David Duncan 2022-01-17 22:41:31 UTC
Completing the proposal tonight. Submission in the morning.

Comment 7 Ben Cotton 2022-02-17 17:21:51 UTC
sgallagh has a PR at https://src.fedoraproject.org/rpms/fedora-release/pull-request/215

Comment 8 Stephen Gallagher 2022-02-18 15:41:20 UTC
The proposed PR is being debated hotly (as intended; I consciously picked the most divisive option in order to ensure a discussion happens). I've opened a Council ticket https://pagure.io/Fedora-Council/tickets/issue/389 to get an official stance on how we should proceed.

Comment 9 Zbigniew Jędrzejewski-Szmek 2022-02-18 15:48:38 UTC
I completely fell for it ;)

Comment 10 Adam Williamson 2022-03-16 17:49:56 UTC
The Council ultimately voted to waive this as a blocker for Fedora 36:

https://pagure.io/Fedora-Council/tickets/issue/389#comment-785482

I pointed out that there wasn't really any clear mechanism for the Council to be allowed to do that, so we invented one:

https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/EFTMMXJYAZOW5CHBCON6UHWCUYWF34OY/

Nobody objected to that, so it's now been implemented:

https://fedoraproject.org/w/index.php?title=Fedora_36_Final_Release_Criteria&diff=638260&oldid=637469

So, the Council waiver vote can now be applied, and this is waived as a blocker for F36. I will push it out to F37. I believe the idea is for Cloud to possibly be an Edition again by then, in which case this bug would be closed as NOTABUG or CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.