This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 201828 - XaraLX-examples should not install into /usr/share/doc/XaraLX
XaraLX-examples should not install into /usr/share/doc/XaraLX
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XaraLX (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 01:29 EDT by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 08:15:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-08-09 01:29:38 EDT
Currently XaraLX-examples installs into:

/usr/share/doc/XaraLX/examples

This is incorrect, if a program installs into the /usr/share/doc space it should
include the version number:

/usr/share/doc/XaraLX-0.7/

or it could also (perhaps preferably) into:

/usr/share/XaraLX/

Many other applications install their example files into the /usr/share/ space
such as LyX, e.g.:

/usr/share/lyx/examples/
Comment 1 Paul F. Johnson 2006-08-09 06:45:44 EDT
Not sure this is actually a bug, but I'll seek guidance.

The contents of the doc package has not actually changed since Xara 0.2, so it
was felt during the review that it should remain as unassigned to any particular
version (hense the lack of -0.7 at the end of the name).

It's not a major change to alter the spec file, but I'll see what others come up
with.
Comment 2 Alex Lancaster 2006-08-09 07:11:29 EDT
That's why I suggest /usr/share/XaraLX/  which is for data that isn't specific
to a particular version

/usr/share/doc/ is for documentation specifically for each version, if you look
in there you'll see that every directory has the specific version of the app.

Most apps like this put data into /usr/share/<appnam>/ rather than
/usr/share/doc/<appname>/
Comment 3 Rex Dieter 2006-08-09 07:22:37 EDT
>Currently XaraLX-examples installs into:
>/usr/share/doc/XaraLX/examples
>This is incorrect, if a program installs into the /usr/share/doc space it should
>include the version number:
>/usr/share/doc/XaraLX-0.7/

IMO, it's not (necessarily) wrong to install into a non-versioned dir under
/usr/share/doc.
Comment 4 Alex Lancaster 2006-08-09 07:36:11 EDT
In my /usr/share/doc/ there are only 3 directories that aren't versioned:

audacity (from audacity from livna, which is probably actually a bug)
HTML (from fedora-release-5-5 which is used to hold system-wide docs)
packages (from kdelibs-3.5.3-0.4.fc5)

In this case it's particularly confusing when there are two directories almost
the same:

/usr/share/doc/XaraLX
/usr/share/doc/XaraLX-0.7/

lyx for example puts it's example files into /usr/share/lyx/examples as many
other packages do.  That's why I suggest /usr/share/XaraLX/.  (Or less
optimally: /usr/share/doc/XaraLX-0.7/)
Comment 5 Rex Dieter 2006-08-09 07:48:41 EDT
> In my /usr/share/doc/ there are only 3 directories that aren't versioned:

There are a few other packages that use unversioned directories, including (but
not limited to) qt4, Macaulay2.

>In this case it's particularly confusing when there are two directories almost
>the same:
>/usr/share/doc/XaraLX
>/usr/share/doc/XaraLX-0.7/

*Shrug*.  To me, this simply implies that the stuff in XaraLX-0.7 is
version-specific, whereas the items under XaraLX is not.
Comment 6 Paul F. Johnson 2006-08-09 08:15:42 EDT
I think I'll side with Rex on this and mark this as not a bug. If though one of
the FESCo cheeses advises both Rex and myself are wrong, I'll re-open the bug
Comment 7 Alex Lancaster 2006-08-09 08:28:17 EDT
There should probably be some kind of policy or information on the packaging
guidelines: http://fedoraproject.org/wiki/Packaging/Guidelines on this.

Note You need to log in before you can comment on or make changes to this bug.