This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 201830 - package has failed dependency
package has failed dependency
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wv2 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 02:25 EDT by james
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 08:24:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2006-08-09 02:25:04 EDT
Description of problem:
error: Failed dependencies:
        libgsf-1.so.113 is needed by wv2-0.2.3-1.fc5.i386

Maybe they meant libgsf-1.so.1.13?


Same for package "wv".
Comment 1 Michael Schwendt 2006-08-09 08:24:43 EDT
No, libgsf-1.so.113 is correct and included in the libgsf-1.13.3-2.2.1
packages of FC5.

Make sure you don't have Fedora Core Development enabled by accident.
It includes a newer libgsf (114) and hence is incompatible.
Comment 2 james 2006-08-09 11:11:50 EDT
Package libgsf-1.13.3-2.2.1 appears to be obsolete - libgsf-1.14.1-4 is the
current libgsf package.  Somebody should update wv and wv2 to be consistent with
the rest of FC5.
Comment 3 Michael Schwendt 2006-08-09 13:58:45 EDT
Just don't enable Fedora Core Development when you want to keep FC5.

There is no libgsf-1.14.1-4 for FC5, FC5 Released Updates or
FC5 Test Updates.
Comment 4 james 2006-08-10 00:42:26 EDT
Ok, sure enough, libgsf-1.14.1-4 is from the development branch.  The thing is,
I _don't_ have the development repo enabled - except that I must have enabled
that when I updated to the development gnucash, which grabs libgsf-1.14.1.

This is sort of an rpm/yum issue, since the older libraries cannot be
automatically installed, alone, as needed.  But that simply leaves me going
after the development versions of wv and wv2 - which exist.  Simple enough.

Sorry for the bother.

Note You need to log in before you can comment on or make changes to this bug.