Bug 201836 - fc5 autofs fails to automount nisplus (NIS+) homes
fc5 autofs fails to automount nisplus (NIS+) homes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 05:31 EDT by Thierry Sengstag
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 04:45:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thierry Sengstag 2006-08-09 05:31:58 EDT
Description of problem:
Under FC5 the autofs startup script /etc/init.d/autofs fails to start
automounting nisplus homes. Automounting nisplus homes manually works:
"/usr/sbin/automount /home nisplus auto_home"

Version-Release number of selected component (if applicable):
# rpm -qa autofs
autofs-4.1.4-29

How reproducible: Always


Steps to Reproduce:
1. /etc/init.d/autofs start
2.
3.
  
Actual results:
System does not show homes.

Expected results:
Homes contents displayed.

Additional info:
First line of /etc/auto.master:
/home nisplus:auto_home
Comment 1 Jeffrey Moyer 2006-08-09 13:39:14 EDT
Please see: http://people.redhat.com/jmoyer and provide the information
requested under the "Filing bug reports" section.  If the script doesn't get so
far as to start the daemon, then let's see the output from sh -x
/etc/init.d/autofs start.

Thanks!
Comment 2 Thierry Sengstag 2006-08-10 04:45:09 EDT
Dear Jeffrey.
sh -x actually shows that autofs issues the correct automount command.  The
problem seems to be on the nisplus side with the keyserv daemon having unstable
behavior after startup thus making autofs fail later on. Sorry for the trouble.

Note You need to log in before you can comment on or make changes to this bug.