Bug 2018558 (CVE-2021-3903) - CVE-2021-3903 vim: heap-based buffer overflow vulnerability
Summary: CVE-2021-3903 vim: heap-based buffer overflow vulnerability
Keywords:
Status: NEW
Alias: CVE-2021-3903
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2018559 2019975
Blocks: 2018560
TreeView+ depends on / blocked
 
Reported: 2021-10-29 17:20 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-11-12 07:29 UTC (History)
18 users (show)

Fixed In Version: vim 8.2.3564
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-10-29 17:20:12 UTC
vim is vulnerable to heap-based buffer overflow.

Reference:
https://huntr.dev/bounties/35738a4f-55ce-446c-b836-2fb0b39625f8

Upstream patch:
https://github.com/vim/vim/commit/777e7c21b7627be80961848ac560cb0a9978ff43

Comment 1 Guilherme de Almeida Suckevicz 2021-10-29 17:20:30 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2018559]


Note You need to log in before you can comment on or make changes to this bug.