Bug 201867 - control-center rpm installs desktop files with gnome prefix
Summary: control-center rpm installs desktop files with gnome prefix
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-09 15:13 UTC by Jean-François Rameau
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-16 05:55:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 9988 None None None Never

Description Jean-François Rameau 2006-08-09 15:13:47 UTC
Description of problem:

control-center rpm installs desktop files with gnome prefix but upstream
packages don't. So, for instance, epiphany browser offers a "Use as desktop
background" function and can't launch background capplet by using its desktop
file since the call is made on "background.desktop" file, not
gnome-background.desktop (see background_download_completed function in
src/popup-commands.c)
I think the way the rpm installs desktop files is wrong (desktop-file-install
--vendor gnome ...), but I'm not sure since it is an old way fedora does that :)

Version-Release number of selected component (if applicable):

control-center-2.15.90-4.fc6

Comment 1 Ray Strode [halfline] 2006-08-09 15:22:04 UTC
Hi,

It's certainly convention, although, I'm not quite sure why we do it.

I'm pretty sure desktop-file-install requires a --vendor argument, but we could
pass just the basename (minus the .desktop extension) as the vendor (or just fix
desktop-file-install to not require a --vendor argument)

Comment 2 Bastien Nocera 2007-02-15 18:53:02 UTC
Filed https://bugs.freedesktop.org/show_bug.cgi?id=9988 about being able to
disable the renaming (ie. allowing an empty vendor).

Comment 3 Matthias Clasen 2007-02-16 05:55:26 UTC
unfortunately, dropping --vendor is not really an option since that breaks other
things that refer to the desktop file by filename, e.g. menu editing. 

Anyway, setting background images in epiphany seems to work just fine in rawhide.

Comment 4 Jean-François Rameau 2007-02-16 09:39:10 UTC
True. We have been hacking epiphany to circumvent the problem:


2007-01-08  Diego Escalante Urrelo <diegoe@svn.gnome.org>

	* src/popup-commands.c: (background_download_completed)

	Check the result of ephy_file_launch_desktop_file () so if it fails we
	try an alternative naming of the background capplet: gnome-background.
	This is seen in fedora. Bug #387206, which is actually caused by
	bugzilla.redhat.com #201867.


Note You need to log in before you can comment on or make changes to this bug.