Bug 2019519 - [sig-builds][Feature:Builds] clone repository using git:// protocol should clone using git:// if no proxy is configured [Skipped:Disconnected] [Suite:openshift/conformance/parallel]
Summary: [sig-builds][Feature:Builds] clone repository using git:// protocol should cl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Test Framework
Version: 4.10
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.8.z
Assignee: Devan Goodwin
QA Contact:
URL:
Whiteboard:
Depends On: 2019518
Blocks: 2019520
TreeView+ depends on / blocked
 
Reported: 2021-11-02 17:55 UTC by OpenShift BugZilla Robot
Modified: 2021-11-11 20:12 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-11 20:12:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 26562 0 None open [release-4.8] Bug 2019519: Skip test 'clone repository using git:// protocol should clone using git:// if no proxy is co... 2021-11-02 19:01:55 UTC
Red Hat Product Errata RHBA-2021:4109 0 None Waiting on Red Hat [RFE] Disable podman ctr.log system-wide 2022-04-12 13:40:18 UTC

Description OpenShift BugZilla Robot 2021-11-02 17:55:57 UTC
+++ This bug was initially created as a clone of Bug #2019516 +++

Cloning for the short term solution which is to skip the test.

+++ This bug was initially created as a clone of Bug #2019433 +++

Description of problem:
CI jobs are failing with `The unauthenticated git protocol on port 9418 is no longer supported.`  

Failing job specific to sig-builds: 
https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_console/10341/pull-ci-openshift-console-master-e2e-gcp/1455327531476455424

Sample of failing jobs:
https://search.ci.openshift.org/?search=The+unauthenticated+git+protocol+on+port+9418&maxAge=48h&context=1&type=build-log&name=&excludeName=&maxMatches=5&maxBytes=20971520&groupBy=job

Version-Release number of selected component (if applicable):
Numerous 4.x

How reproducible:
Consistently

Steps to Reproduce:
1. Run openshift-tests
2.
3.

Actual results:
[sig-builds][Feature:Builds] is failing due to reported unsupported git protocol.

Expected results:
[sig-builds][Feature:Builds] should use supported mechanism for interacting with git.

Additional info:

--- Additional comment from Surender Yadav on 2021-11-02 16:09:32 UTC ---

CI jobs are failing with `The unauthenticated git protocol on port 9418 is no longer supported" for s390x as well.

Failing job specific to sig-builds: 
https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/periodic-ci-openshift-multiarch-master-nightly-4.6-ocp-e2e-remote-libvirt-s390x/1455308719846854656
https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/periodic-ci-openshift-multiarch-master-nightly-4.9-ocp-e2e-remote-libvirt-s390x/1455505091434909696

Sample of failing jobs:
https://search.ci.openshift.org/?search=The+unauthenticated+git+protocol+on+port+9418+is+no+longer+supported&maxAge=168h&context=1&type=build-log&name=s390x&excludeName=&maxMatches=5&maxBytes=20971520&groupBy=job

Version-Release number of selected component (if applicable):
Numerous 4.9 & 4.6

--- Additional comment from Devan Goodwin on 2021-11-02 17:21:42 UTC ---

I am working on a PR to disable this in 4.10 and backport throughout, but will leave this bugzilla open for a proper fix.

Comment 3 errata-xmlrpc 2021-11-11 20:12:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.19 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4109


Note You need to log in before you can comment on or make changes to this bug.