Bug 201955 - SEGV in /usr/bin/id for userid w/ more than 4 to 6 groups
SEGV in /usr/bin/id for userid w/ more than 4 to 6 groups
Status: CLOSED DUPLICATE of bug 200327
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: coreutils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2006-08-09 18:30 EDT by Don Meyer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-10 07:04:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Don Meyer 2006-08-09 18:30:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20060728 Firefox/

Description of problem:
After upgrading our RHEL3 systems to update 8 level, including the coreutils-4.5.3-28.1 package, several of our scripts started failing for specific users.  The commonality was users which belonged to multiples of groups defined on the system.

We traced this down to the /usr/bin/id utility in particular.   Whenever a user belonged to more than three groups, "id userid" would SegFault.  (membership count includes primary group.)  Oddly, "id -G userid" would still work at four group memberships, but would fail at five.

Our isolation method also serves as our workaround -- we obtained the SRPM for coreutils-4.5.3-28, rebuilt the binary RPM and force installed it.   This restored proper function.   Updated to 4.5.3-28.1 using up2date, and the problems returned.  Force install ( -U, really...) back to 4.5.3-28 and problem goes away.

Ergo, the problem definitely lies in the coreutils-4.5.3-28.1 package somewhere.

I should also note that while /usr/bin/id was SegFaulting for a particular userid, /usr/bin/groups would return absolutely no output when run for the same userid.  This may help narrow the problem's cause...

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.pick a userid on a system
2.create three new groups, each with this userid as member.
3.run "id {userid}" - you should get a Segmentation Fault.
4.run "groups {userid}" -- you should not receive any output.

Actual Results:
After #3, Segmentation Fault
After #4, no output

Expected Results:
After #3, information about the userid's uid & gid, plus a list of groups(gids) should have been displayed.

After #4, a list of groups to which the userid belongs should have been displayed.

Additional info:
Since this does not cause an actual crash or memory leak, I hesitate to class this as high severity.   However, it does have the potential to break a lot of custom scripts out there, and probably in some pretty strange ways...
Comment 1 Tim Waugh 2006-08-10 07:04:03 EDT

*** This bug has been marked as a duplicate of 200327 ***

Note You need to log in before you can comment on or make changes to this bug.