Bug 201956 - two soundcards in firstboot sound configuration, should have been 1.
two soundcards in firstboot sound configuration, should have been 1.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 18:31 EDT by Olen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 08:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sound card config log (61.13 KB, text/plain)
2006-08-10 13:43 EDT, Olen
no flags Details
screenshot via selected (30.44 KB, image/png)
2006-08-11 14:12 EDT, Olen
no flags Details
screenshot with wierd PNP card selected (27.51 KB, image/png)
2006-08-11 14:13 EDT, Olen
no flags Details
lshal output (120.10 KB, application/octet-stream)
2006-08-11 14:14 EDT, Olen
no flags Details

  None (edit)
Description Olen 2006-08-09 18:31:28 EDT
Description of problem:
 Sound Card Configure found the proper sound card, but also found an
extra sound card not in the system. Only the VIA sound drivers worked
and test sound was fine. So I think sound card detection needs a bit
of work.  The extra sound card had a nonsensical name as well, started with a P
and was mostly numbers, maybe one other character, probably 8 chars wide.

Version-Release number of selected component (if applicable):
fc6 test 2 DVD iso version

How reproducible:
Only installed once, so haven't tried to reproduce this problem.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
2 sound cards found

Expected results:
Just VIA sound card to be found in my box.

Additional info:
System AMD 64 bit Athlon 2400
200 GB SATA hard drive
512 MB Ram Memory
Gigabit ethernet
USB - printer HP PSC 1210
6600 GT Nvidia Video Card ( I don't often install NVIDIA's drivers,
if I'm not doing something that needs the extra performance. )
17" Samsung monitor synmaster 750s
On board VIA sound
ASUS A8V-E Deluxe Motherboard.
The monitor,keyboard, and mouse, are shared with another computer via a KVM.

This information came from my post on fedoraforum.org title:
FC6 Test 2 i386 observations
Comment 1 Martin Stransky 2006-08-10 02:16:06 EDT
Please attach /root/scsconfig.log file.
Comment 2 Olen 2006-08-10 13:43:54 EDT
Created attachment 133960 [details]
sound card config log

In this log, it was the isa PNP  audio interface  that showed up
as another sound card in the window.
Comment 3 Martin Stransky 2006-08-11 05:35:15 EDT
Could you please attach output of lshal and screenshot of s-c-s where is the
wrong card detected?
Comment 4 Olen 2006-08-11 14:12:28 EDT
Created attachment 134050 [details]
screenshot via selected
Comment 5 Olen 2006-08-11 14:13:22 EDT
Created attachment 134052 [details]
screenshot with wierd PNP card selected
Comment 6 Olen 2006-08-11 14:14:07 EDT
Created attachment 134053 [details]
lshal output
Comment 7 Martin Stransky 2006-08-14 08:04:56 EDT
It's the mpu401 device, It isn't a bug.
Comment 8 Olen 2006-08-14 09:37:45 EDT
Thanks for the information.   Is the mpu401 device just a subfunction
of the VIA card for sound input from keyboards?  I used to think it was, but I
know little about sound cards, and MIDI,  I just want some basic sound to play,
which the sound card configuration gets working fine (thanks).
But if the MPU is just a function of the VIA built in soundcard, I would suggest
having its MPU be configured on the VIA tab.  If other OSes configure the two as
seperate devices though, then I Fedora should follow the defacto standard in the
area, and keep them as seperate sound cards.
Comment 9 Martin Stransky 2006-08-18 03:00:41 EDT
I'm not sure whether I can change it, s-c-soundcard just uses informations which
come from kernel. The MPU-401 is a generic MIDI I/O interface for PC and can be
used for sound input from keyboards, so this may be your case.

Note You need to log in before you can comment on or make changes to this bug.