Bug 201966 - Anaconda can't find my HDD on sata_promise
Anaconda can't find my HDD on sata_promise
Status: CLOSED DUPLICATE of bug 199142
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 19:36 EDT by Dawid Zamirski
Modified: 2013-07-02 22:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 14:24:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of the error message with 2.6.18-1.2189 kernel. (114.98 KB, image/jpeg)
2006-09-26 18:29 EDT, Dawid Zamirski
no flags Details

  None (edit)
Description Dawid Zamirski 2006-08-09 19:36:27 EDT
Description of problem:
I have just  attempted to install FC6T2 from a DVD and during anaconda
intialization it displayed a lot of garbage text and I could see sata_promise
driver loading. After that a message poped up that it couln't find any drives
and asked if I want to load one. I choosing either "yes" or "no" loads the
graphical installer and after the "searching for Fedora Core installations" step
a diealog pops up satting that there are no hard drives. My hard drives are
brand new and I installed on them a clean FC5 yesterday. Both drived are
connected to Promise FastTrack 579 SATA controller in RAID 0 mode on MSI K8T
Neo2 motherboard. I believe that there's issome problem with the kernel driver
because I'm also unable to boot 2.6.17.X series from the stable FC5 (such bug
reports were already filled against FC5 on 2.6.17)

How reproducible:
Always

Steps to Reproduce:
1. Boot from the FC6T2 DVD
2. Press enter at the boot prompt (also tried with nodmraid)
3. sata_promise seems to load but there is a lot of garbage text on the screen
and finally error mesage appears that there are no drives at all.
3.
  
Actual results:
Failed to install FC6T2

Expected results:
Sucessfull install of FC6T2 and antoher set of bug reports :-)
Comment 1 Dawid Zamirski 2006-09-18 23:32:02 EDT
I was able to partially solve the issue in FC5 kernel (the 2.6.17 series) by
rebuilding the kernel's src.rpm with linux-2.6-sata-promise-pata-ports.patch
commented out in the spec file. After I removed the patch the newest Core 5
boots sucesfully. I think that current FC Rawhide suffers excatly from the same
bug in the patch. Unfortunately I don't know how to debug kernel Oops yet so
that I could   spot the bug and provide more info on the subject. I'll play more
with it tomorrow and will let you know if I get any useful information.
Comment 2 Dawid Zamirski 2006-09-26 18:29:13 EDT
Created attachment 137181 [details]
Photo of the error message with 2.6.18-1.2189 kernel.
Comment 3 Dawid Zamirski 2006-11-13 14:24:06 EST

*** This bug has been marked as a duplicate of 199142 ***

Note You need to log in before you can comment on or make changes to this bug.