Bug 201974 - e1000: counters look wrong
Summary: e1000: counters look wrong
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 213939
TreeView+ depends on / blocked
 
Reported: 2006-08-10 03:06 UTC by Bill Nottingham
Modified: 2014-03-17 03:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 21:01:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix garbled stats (774 bytes, patch)
2006-11-03 19:53 UTC, Neil Horman
no flags Details | Diff

Description Bill Nottingham 2006-08-10 03:06:27 UTC
Description of problem:


eth0      Link encap:Ethernet  HWaddr 00:0D:60:39:C0:63  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1012261 errors:4294967284 dropped:4294967294 overruns:0
frame:4294967288
          TX packets:562134 errors:4294967292 dropped:0 overruns:0
carrier:4294967290
          collisions:4294967294 txqueuelen:100 
          RX bytes:1372147058 (1.2 GiB)  TX bytes:88847078 (84.7 MiB)
          Base address:0x8000 Memory:c0220000-c0240000 

Something about some of those numbers doesn't look right.

Version-Release number of selected component (if applicable):

2.6.17-1.2530.fc6

# ethtool  -i eth0
driver: e1000
version: 7.1.9-k4-NAPI

Comment 1 John W. Linville 2006-09-25 20:06:17 UTC
Please try the test kernels here:

   http://people.redhat.com/linville/kernels/fc6/

Do these exhibit similar stats problems?

Comment 2 Bill Nottingham 2006-09-27 18:28:39 UTC
[notting@nostromo: ~]$ uname -a
Linux nostromo.devel.redhat.com 2.6.18-1.2685.2.1.fc6.jwltest.7 #1 SMP Thu Sep
21 14:47:00 EDT 2006 i686 i686 i386 GNU/Linux
[notting@nostromo: ~]$ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:0D:60:39:C0:63  
          inet addr:172.16.56.99  Bcast:172.16.59.255  Mask:255.255.252.0
          inet6 addr: fe80::20d:60ff:fe39:c063/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:77646 errors:4294967290 dropped:4294967295 overruns:0
frame:4294967292
          TX packets:22746 errors:4294967294 dropped:0 overruns:0 carrier:4294967293
          collisions:4294967295 txqueuelen:1000 
          RX bytes:34519128 (32.9 MiB)  TX bytes:5238132 (4.9 MiB)
          Base address:0x8000 Memory:c0220000-c0240000 
[root@nostromo notting]# ethtool -i eth0
driver: e1000
version: 7.2.7-k2-NAPI
firmware-version: N/A
bus-info: 0000:02:01.0

Seems to be the same. The counters seem to go wacky after resume from
suspend-to-ram.

Comment 3 Auke Kok 2006-09-27 20:48:21 UTC
I've seen it, but can't confirm that it's a driver problem. I'll need more time
on it.

Comment 4 Auke Kok 2006-10-25 21:55:41 UTC
check ethtool -S ethX - you'll see they're all 0xffffffff values, something is
reading the stats before the pci device is back online.

Comment 5 Auke Kok 2006-11-03 19:09:31 UTC
I have a fix which will be sent to netdev shorty.

Comment 6 Neil Horman 2006-11-03 19:53:13 UTC
Created attachment 140306 [details]
patch to fix garbled stats

patch Which Auke sent to John and myself for backporting

Comment 7 Neil Horman 2006-11-03 21:01:39 UTC
closing this as its going upstream


Note You need to log in before you can comment on or make changes to this bug.