Bug 20199 - nmapfe dumps core when scanning a Solaris 7 box
Summary: nmapfe dumps core when scanning a Solaris 7 box
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: nmap (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-02 11:09 UTC by Sarantis Paskalis
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 14:35:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sarantis Paskalis 2000-11-02 11:09:44 UTC
nmapfe dumps core when scanning a Solaris 7 box.
nmap produces correct results.
RPMS: nmap-2.53-5, namp-frontend-2.53-5

specifics:
launch nmapfe, scan a Solaris 7 box as nmap -sS -O xxx.xxx.xxx.xxx
dumps core

launch nmapfe, scan the same box as nmap -sS -R xxx.xxx.xxx.xxx
ok
scan again as nmap -sS -O xxx.xxx.xxx.xxx
ok!!!

Comment 1 Tim Powers 2000-11-02 13:59:06 UTC
Is this happening when just using nmap or just with nmapfe? I'm just trying to
make sure so that the maintainers of nmap/nmapfe are aware of the problem.

Tim


Comment 2 Tim Powers 2000-11-02 14:10:08 UTC
Wait. I misread your report. Sorry. Do later versions of nmapfe work correctly
on a Solaris 7 machine? The reason I'm asking is beacuse I don't have one I
could test on.

Tim


Comment 3 Sarantis Paskalis 2000-11-02 14:38:02 UTC
I could not download 2.54BETA7 from www.insecure.org to test it out.  The site
seems unreachable right now.

Comment 4 Tim Powers 2000-11-02 14:44:20 UTC
I found an alternate download. I'm putting together packages of it now. I'll let
you know where to get them once they are finished.

Tim


Comment 5 Tim Powers 2000-11-02 16:46:08 UTC
I have uploaded the new package for you to test. You can get them from:

http://people.redhat.com/timp/RPMS/nmap-2.54BETA7-1.i386.rpm
http://people.redhat.com/timp/RPMS/nmap-frontend-2.54BETA7-1.i386.rpm

and the SRPM from:

http://people.redhat.com/timp/SRPMS/nmap-2.54BETA7-1.src.rpm

Let me know whether it works or not. Oh, sorry for the delay, had to go to a
meeting.

Tim


Comment 6 Sarantis Paskalis 2000-11-03 12:07:39 UTC
Ok, it seems to work after some tweeking.
Details:  Scanning the same Solaris box as nmap -sS -O ... (default)

Binary rpms do not go any further stating that:
OS scan requested but I cannot find nmap-os-fingerprints file.  It should be in
/usr/share/nmap, ~/.nmap/ or .
QUITTING!

After I built the rpms from the SRPM, doing a rpm -bb, and installed it
afterwards, it worked ok (no core dump).

It seems that it created a /usr/share/nmap/ directory with various files, not
owned by any package.  This directory though does not belong to any rpm, and was
probably added during the rpm -bb phase.

Possible solution: include it in the spec file, so that /usr/share/nmap/* is
part of the nmap rpm.

Comment 7 Tim Powers 2000-11-03 13:48:21 UTC
Actually it was an error in the spec file that I didn't catch. I forgot to
include $RPM_BUILD_ROOT in the install path for $(nmapdatadir). I built another
package, located in the same place:

http://people.redhat.com/timp/RPMS/nmap-2.54BETA7-2.i386.rpm
http://people.redhat.com/timp/RPMS/nmap-frontend-2.54BETA7-2.i386.rpm

and the SRPM:

http://people.redhat.com/timp/SRPMS/nmap-2.54BETA7-2.src.rpm

Please try this one out. It should work now.

Tim


Comment 8 Sarantis Paskalis 2000-11-03 14:08:11 UTC
Ok, that seemed to do the trick.
Thanks.

Sarantis

Comment 9 Tim Powers 2000-11-03 14:35:31 UTC
OK. I have it going through the QA process now. I'm closing this bug with the
resolution of "errata".

Tim


Comment 10 Tim Powers 2000-11-06 21:10:12 UTC
Just so that you know, an errata was released today on this.

Tim



Note You need to log in before you can comment on or make changes to this bug.