Bug 20201 - RFE: Remove rsh as a OpenSSH dependency
RFE: Remove rsh as a OpenSSH dependency
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-02 06:21 EST by Andrew Bartlett
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 22:07:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2000-11-02 06:21:45 EST
I prefer not to have any unnecercery set-uid binaries, and as such I remove
rsh from the servers I operate.  I would like to see rsh removed as a
dependency for OpenSSH.

(I realise I can do --nodeps or just remove the set-uid bit, but it would
be nice to just be able to remove the package).

Thanks,
Comment 1 Pekka Savola 2000-11-02 16:44:08 EST
rsh is only a _build_ requirement, so the situation isn't that bad.

However, I don't like to have rsh installed on systems I use for RPM rebuilding either ;-)
Comment 2 Nalin Dahyabhai 2000-11-02 16:52:46 EST
We include /usr/bin/rsh because if we don't, the configure script will have to
guess its location.  And it can guess wrong.  Adding it as a build-time
requirement will also flag it as an error if (for whatever reason) /usr/bin/rsh
moves.
Comment 3 R P Herrold 2001-02-25 12:25:35 EST
Hi, Nalin,

As you know, Pekka is active with the openssh port -- Are you ameanable to a
patch to remove the configure.in search (and bad guess when absent) for
/usr/bin/rsh -- the only way the tombstones art of OpenBSD 2.7 will be accurate
is if we take steps to get RID of telnetd, rsh, rlogin, (and in an HP
environment remsh).

-- Russ
Comment 4 Nalin Dahyabhai 2001-02-26 15:35:32 EST
A patch would be great, but I'm trying to keep the degree to which we deviate
from the openssh.com packages down to changes which make sense for no one else,
so this might best be sent upstream.
Comment 5 R P Herrold 2001-10-25 21:05:45 EDT
This seems to have been adopted in the .spec file:
* Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>

As I am not the requester, I will not close, but would ask Nalin, or  
abartlet@samba.org to consider closing it as "CURR"

Note You need to log in before you can comment on or make changes to this bug.