Bug 202044 - ssRawCpu* stays on 2^32-1 forever.
ssRawCpu* stays on 2^32-1 forever.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-snmp (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 11:20 EDT by James Lamb
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0458
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:38:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Lamb 2006-08-10 11:20:22 EDT
Description of problem:


When I query a RH ES v3 u7 server using snmp for idle ticks which should
indicate that the server is loaded or not. After a large amount of uptime (circa
240days) the servers all report the idle ticks not increasing even though the
server has been idle for some time. If I run the following command  awk '/^cpu /
{print $5}' /proc/stat I can see that the counter is still incrementing but
snmpd reports

UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: 4294967295

When I query with the following OID enterprises.ucdavis.systemStats

No matter how long the system is up it will always report the variable
4294967295, even if the system is 100% idle.

I have done some extensive research and it looks as though the problem is
resolved with the following patch from the net-snmp cvs.

http://net-snmp.cvs.sourceforge.net/net-snmp/net-snmp/agent/mibgroup/ucd-snmp/vmstat.c?r1=5.7&r2=5.8



How reproducible:
Very Easy.

Steps to Reproduce:

snmpwalk -v 2c -c private localhost  enterprises.ucdavis.systemStats | grep Idle
; sleep 60 ; snmpwalk -v 2c -c private localhost 
enterprises.ucdavis.systemStats | grep Idle

  
Actual results:

UCD-SNMP-MIB::ssCpuIdle.0 = INTEGER: 99
UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: 4294967295


Expected results:

UCD-SNMP-MIB::ssCpuIdle.0 = INTEGER: 99
UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: [[4294967295]] 

Where the [[]] Number should have incremented as the server is idle.



Additional info:
This problem appears to occur in all Redhat EL v3 servers that we have with huge
uptime. 

After reading around on the internet I have found several people with an
identical issue. From what It looks like this is the patch to resolve the problem. 

http://net-snmp.cvs.sourceforge.net/net-snmp/net-snmp/agent/mibgroup/ucd-snmp/vmstat.c?r1=5.7&r2=5.8&diff_format=c

There are also debian users with similar problems.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=308018
Comment 1 Radek Vokal 2006-08-11 02:28:21 EDT
Thanks, I propose this issue for next update. 
Comment 7 Red Hat Bugzilla 2007-06-11 14:38:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0458.html

Note You need to log in before you can comment on or make changes to this bug.