Bug 2020453 - Ncat won't work with --proxy
Summary: Ncat won't work with --proxy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nmap
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Martin Osvald 🛹
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2020888 2024007 2032419 2044364 (view as bug list)
Depends On: 1991184
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-04 22:23 UTC by Göran Uddeborg
Modified: 2022-03-26 15:00 UTC (History)
11 users (show)

Fixed In Version: nmap-7.92-1.fc35 nmap-7.92-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-25 16:51:56 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github nmap nmap issues 2149 0 None closed ncat not work with --proxy at version 7.90, 7.91 2021-11-04 22:23:21 UTC

Description Göran Uddeborg 2021-11-04 22:23:22 UTC
Description of problem:
After upgrade to Fedora 35, my SSH proxy settings using nc no longer works. The connection is terminated immediately.


Version-Release number of selected component (if applicable):
nmap-ncat-7.91-8.fc35.x86_64


How reproducible:
Every time


Steps to Reproduce:
1. nc --proxy-type socks5 --proxy <proxy.host> <target.machine> 22


Actual results:
Terminates immediately


Expected results:
SSH banner


Additional info:
According to the upstreams bug, this should be fixed in version 7.92.

Comment 1 Pavel Zhukov 2021-11-08 10:57:49 UTC
*** Bug 2020888 has been marked as a duplicate of this bug. ***

Comment 2 Mark McLoughlin 2022-02-22 15:28:47 UTC
bug #1991184 tracks the update to 7.92

Comment 3 Mark McLoughlin 2022-02-22 15:31:16 UTC
*** Bug 2032419 has been marked as a duplicate of this bug. ***

Comment 4 Mark McLoughlin 2022-02-22 15:33:29 UTC
*** Bug 2044364 has been marked as a duplicate of this bug. ***

Comment 5 Mark McLoughlin 2022-02-22 15:35:59 UTC
*** Bug 2024007 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2022-02-23 13:35:02 UTC
FEDORA-2022-d48d5031c8 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d48d5031c8

Comment 7 Fedora Update System 2022-02-23 13:46:30 UTC
FEDORA-2022-db05340ff9 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-db05340ff9

Comment 8 Fedora Update System 2022-02-23 16:08:32 UTC
FEDORA-2022-db05340ff9 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-db05340ff9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-db05340ff9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-02-24 01:45:22 UTC
FEDORA-2022-d48d5031c8 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-d48d5031c8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d48d5031c8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-02-25 16:51:56 UTC
FEDORA-2022-db05340ff9 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2022-03-26 15:00:16 UTC
FEDORA-2022-d48d5031c8 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.