Bug 2020633 - XOrg frequently crashes when using qxl driver on fc34. qxl(0): error doing QXL_ALLOC
Summary: XOrg frequently crashes when using qxl driver on fc34. qxl(0): error doing QX...
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Alon Levy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-05 13:12 UTC by Jorge Olmos
Modified: 2022-11-07 14:21 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
log file after Xorg is restarted (24.46 KB, text/plain)
2021-11-05 13:12 UTC, Jorge Olmos
no flags Details
syslog (25.23 KB, text/plain)
2022-06-14 19:25 UTC, Basic Six
no flags Details
Xorg crash (17.15 KB, text/plain)
2022-06-14 19:39 UTC, Basic Six
no flags Details

Description Jorge Olmos 2021-11-05 13:12:15 UTC
Created attachment 1840163 [details]
log file after Xorg is restarted

Description of problem:
XOrg crashes when using qxl driver after "a few minutes".

It started happening after rebooting a vm after installing updates.

I have narrowed it down to using a "new" kernel.
*This happens when I run 5.14.15-200.fc34.x86_64 kernel in the guest, but NOT when I run 5.11.12-300.fc34.x86_64*

All the packages of fedora 34 are fully updated.

Version-Release number of selected component (if applicable):

I currently use
 xorg-x11-drv-qxl.x86_64  0.1.5-19.fc34                                                 
(latest)
xorg-x11-server-Xorg.x86_64 1.20.11-1.fc34 

But I downgraded xorg-x11-drv-qxl, and xorg-x11-server-Xorg it happened too.


How reproducible:
5 times in a row, in less than 3 minutes each.

Steps to Reproduce:
1. Install Fedora 34 in a qemu-kvm machine with a qxl graphic video device. Use some X based graphics, like i3 WM, or gnome on Xorg.

2. Fully update Fedora 34. Specifically, use the latest kernel (now it is 5.14.15-200.fc34.x86_64)

3. Open an spice connection to the console of the vm in a large window like 2560x1440, or 1920x1080 Smaller resolutions make the error less frequent.
4. Open firefox in a large window.
5. Open reddit.com in one tab. Scroll down for a moment. Play a video
6. Create new tab in firefox. open youtube.com . Play a video.
7. Go back to first tab


Actual results:
Xorg crashes before finishing all the steps.
See attached file

Expected results:
It all works.

Additional info:

I have been using the machine 8 hours/day for a week without any crash running an updated fc34, except for kernel 5.11.12-300.fc34.x86_64

If I boot the latest kernel, 5.14.15-200.fc34.x86_64, without updating any package, or reconfiguring anything,  Xorg crashes frequently.


I have filed this against xorg-x11-qxl-drv because the Xorg.0.log.old shows this after a crash:

[  1478.105] (EE) qxl(0): error doing QXL_ALLOC
[  1478.107] (EE)
[  1478.107] (EE) Backtrace:
[  1478.113] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x56138bcb0cd9]
[  1478.115] (EE) 1: /lib64/libpthread.so.0 (funlockfile+0x60) [0x7fdfd9a2aa20]
[  1478.117] (EE) unw_get_proc_name failed: no unwind info found [-10]
[  1478.117] (EE) 2: /usr/lib64/xorg/modules/drivers/qxl_drv.so (?+0x0) [0x7fdfd8cbca35]
...
[  1478.123] (EE) 9: /usr/libexec/Xorg (_start+0x2e) [0x56138bb4167e]
[  1478.124] (EE)
[  1478.124] (EE) Segmentation fault at address 0x0
[  1478.124] (EE)
Fatal server error:
[  1478.124] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  1478.124] (EE)

Comment 1 Felix Leimbach 2022-02-11 17:03:11 UTC
I had the exact same problem on Debian. Downgrading from kernel 5.15.0-2 to 5.10.0-10 made the problem disappear.

Comment 2 Jorge Olmos 2022-03-21 13:17:26 UTC
Same crash on a Fedora 35 live-CD without installing/updating any software on it, two minutes after booting.

Error has happened during installation of Fedora-MATE_Compiz-Live-x86_64-35-1.2.iso on a virtual machine with QXL.
It uses kernel 5.14.10-300.

I clicked on "install to disk", configured keyboard, and X crashed killing the installer.

End of Xorg.0.log.old follows:

[...]
[    30.811] (**) Option "config_info" "udev:/sys/devices/virtual/input/input9/event7"
[    30.811] (II) XINPUT: Adding extended input device "spice vdagent tablet" (type: MOUSE, id
12)
[    30.811] (**) Option "AccelerationScheme" "none"
[    30.811] (**) spice vdagent tablet: (accel) selected scheme none/0
[    30.811] (**) spice vdagent tablet: (accel) acceleration factor: 2.000
[    30.811] (**) spice vdagent tablet: (accel) acceleration threshold: 4
[    30.812] (II) event7  - spice vdagent tablet: is tagged by udev as: Mouse
[    30.812] (II) event7  - spice vdagent tablet: device is a pointer
[   122.958] (EE) qxl(0): error doing QXL_ALLOC
[   122.958] (EE)
[   122.958] (EE) Backtrace:
[   122.961] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x55815eb68d09]
[   122.973] (EE) 1: /lib64/libc.so.6 (__sigaction+0x50) [0x7f835971f760]
[   122.974] (EE) unw_get_proc_name failed: no unwind info found [-10]
[   122.974] (EE) 2: /usr/lib64/xorg/modules/drivers/qxl_drv.so (?+0x0) [0x7f8358b4fa3d]
[   122.974] (EE) unw_get_proc_name failed: no unwind info found [-10]
[   122.974] (EE) 3: /usr/lib64/xorg/modules/drivers/qxl_drv.so (?+0x0) [0x7f8358b4fe66]
[   122.975] (EE) unw_get_proc_name failed: no unwind info found [-10]
[   122.975] (EE) 4: /usr/lib64/xorg/modules/drivers/qxl_drv.so (?+0x0) [0x7f8358b5439d]
[   122.975] (EE) unw_get_proc_name failed: no unwind info found [-10]
[   122.975] (EE) 5: /usr/lib64/xorg/modules/drivers/qxl_drv.so (?+0x0) [0x7f8358b5c370]
[   122.976] (EE) 6: /usr/libexec/Xorg (miCopyRegion+0x9b) [0x55815eb4778b]
[   122.976] (EE) 7: /usr/libexec/Xorg (miDoCopy+0x43c) [0x55815eb4a38c]
[   122.977] (EE) unw_get_proc_name failed: no unwind info found [-10]
[   122.977] (EE) 8: /usr/lib64/xorg/modules/drivers/qxl_drv.so (?+0x0) [0x7f8358b5c572]
[   122.977] (EE) 9: /usr/libexec/Xorg (DamageDamageRegion+0x1a39) [0x55815eaf6219]
[   122.978] (EE) 10: /usr/libexec/Xorg (miGlyphs+0x5edb) [0x55815eaebccb]
[   122.978] (EE) 11: /usr/libexec/Xorg (miGlyphs+0x5fb6) [0x55815eaebda6]
[   122.979] (EE) 12: /usr/libexec/Xorg (miGlyphs+0x6ea2) [0x55815eaecc92]
[   122.979] (EE) 13: /usr/libexec/Xorg (present_event_notify+0xaa2) [0x55815eaf0ca2]
[   122.980] (EE) 14: /usr/libexec/Xorg (DisableLocalAccess+0x454) [0x55815eb658f4]
[   122.980] (EE) 15: /usr/libexec/Xorg (WaitForSomething+0x2c2) [0x55815eb65be2]
[   122.980] (EE) 16: /usr/libexec/Xorg (miPutImage+0xe77) [0x55815e9f8bbd]
[   122.981] (EE) 17: /lib64/libc.so.6 (__libc_start_call_main+0x80) [0x7f835970a560]
[   122.982] (EE) 18: /lib64/libc.so.6 (__libc_start_main+0x7c) [0x7f835970a60c]
[   122.983] (EE) 19: /usr/libexec/Xorg (_start+0x25) [0x55815e9f9675]
[   122.983] (EE)
[   122.983] (EE) Segmentation fault at address 0x0
[   122.983] (EE)
Fatal server error:
[   122.983] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   122.983] (EE)
[   122.983] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   122.983] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   122.983] (EE)
[   123.002] (EE) Server terminated with error (1). Closing log file.

Comment 3 Ben Cotton 2022-05-12 14:54:49 UTC
This message is a reminder that Fedora Linux 34 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 34 on 2022-06-07.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '34'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 34 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 4 Jorge Olmos 2022-05-23 08:19:52 UTC
F34 is going EOL soon.
As said in comment 2, same error happens in Fedora 35 too.

Comment 5 Basic Six 2022-06-14 19:25:30 UTC
Created attachment 1889997 [details]
syslog

Thanks to the person who has opened this bug report: This is extremely frustrating. I work with a bunch of Fedora vms and since "dnfdragora" shows annoying update notifications all the time (Bug 2000512), I do update them - which is why they now crash randomly. Each time, I lose about fifty open tabs and notes and it takes time to restore everything to be able to continue working. Initially it happened only in one installation (mainly when using Firefox, so I switched that for a while), I've even installed a copy of that system because I didn't think that a regular update would cause fatal system crashes! I rarely had the time to search through the logs; when I did have the time, I couldn't find anything anything (because the logs are cluttered with screenfuls of useless message blobs like "A start job for unit session-69594.scope has finished successfully Defined-By: systemd ...", whoever thought it would be a good idea to log this by default).

But now, I've managed to copy the log before systemd would write another megabyte of useless messages into it. I'm attaching that log here.
Kernel: 5.17.11-200.fc35.x86_64

A workaround for this Xorg crash is to change the video setting in virt-manager from QXL to Virtio, but then everything will be extremely slow.

Please, does anyone know which update is causing these terrible Xorg crashes now? Is there another bug report here or elsewhere (upstream)?

Comment 6 Basic Six 2022-06-14 19:39:45 UTC
Created attachment 1890009 [details]
Xorg crash

Some more info from gnome-abrt including bt, see attachment.


Note You need to log in before you can comment on or make changes to this bug.