Bug 2021087 - Installation of Fedora Kinoite in a UTC timezone breaks KDE
Summary: Installation of Fedora Kinoite in a UTC timezone breaks KDE
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: 35
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-08 10:36 UTC by Benjamin Holmes
Modified: 2022-06-26 20:22 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-17 15:04:49 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
KDE is presented when logging in after installation with a UTC timezone (48.81 KB, image/jpeg)
2021-11-08 10:36 UTC, Benjamin Holmes
no flags Details
Installation logs from another user who coorborated issue (120.81 KB, application/gzip)
2021-11-08 10:39 UTC, Benjamin Holmes
no flags Details


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 442011 0 NOR UNCONFIRMED kf.plasma.core: findInCache with a lastModified timestamp of 0 is deprecated 2021-11-09 18:49:01 UTC

Description Benjamin Holmes 2021-11-08 10:36:25 UTC
Created attachment 1840688 [details]
KDE is presented when logging in after installation with a UTC timezone

Description of problem:

When installing Fedora Kinoite - or rebasing from Silverblue to Kinoite - when the system is installed as a UTC timezone, the KDE Desktop Environment is broken

Have linked Anaconda as the component as this is the only place at install time you can define the timezone.

Version-Release number of selected component (if applicable):

Fedora Kinoite 35


How reproducible:

Every time


Steps to Reproduce:
1. Run through installation process, selecting a UTC timezone (Europe/london tested) at install time
2. When installation completes, log into KDE

Actual results:
Applications and Links missing from the Application Launcher, white, broken icons for the preferred apps on the bottom panel. Links from both Application Launcher and bottom panel generate errors instead of performing expected actions.

Expected results:
Functional desktop

Additional info:
WOrkaround is to install with a non-UTC timezone and change timezone after installation has completed, and then reboot. This fixes the issue temporarily. It appears that any interaction with rpm-ostree does trigger the issue again, requiring resetting of the timezonesto non-UTC and another reboot.

First raised and discussed here: 
https://discussion.fedoraproject.org/t/kinoite-a-kde-and-now-xfce-version-of-fedora-silverblue/147/296?u=benemon

Top level post to raise awareness here:

https://discussion.fedoraproject.org/t/kinoite-installation-with-utc-timezone-breaks-kde/34293

Comment 1 Benjamin Holmes 2021-11-08 10:39:59 UTC
Created attachment 1840689 [details]
Installation logs from another user who coorborated issue

Comment 2 Timothée Ravier 2021-11-09 18:49:02 UTC
I don't think it's an Anaconda bug. Redirecting to plasma. I've reported it here already: https://bugs.kde.org/show_bug.cgi?id=442011 but now that we have a better reproducer I can work on it / update the upstream report.

Comment 3 Stephane Travostino 2021-11-10 09:23:46 UTC
I don't think that bug is related, Timothée. It's not just missing icons, when installing using a GMT timezone there are no applications at all. The KDE menu is empty, not even system settings starts.

Comment 4 Timothée Ravier 2021-11-15 20:24:47 UTC
The mostly likely issue here is that on Kinoite, all files in /usr are timestamp 0 (thus using the UNIX origin timestamp).
The fact that it manifest only on the UTC timezone might be because on other TZ, something in KDE will convert the date into a "local zone" timestamp/date which then won't be 0.
Thus I think that the linked bug is a most probably a part but I agree that it may not be the entire bug or the full root cause behind this issue.

Comment 5 Thomas Cooper 2022-04-13 22:11:15 UTC
I can confirm this is still an issue on Kinoite Fedora 35. I set the timezone to London BST (UTC+1) during installation and KDE is unusable!

Reinstalling using US Eastern Standard Time leads to a working system.

Comment 6 Thomas Cooper 2022-04-13 22:11:36 UTC
I can confirm this is still an issue on Kinoite Fedora 35. I set the timezone to London BST (UTC+1) during installation and KDE is unusable!

Reinstalling using US Eastern Standard Time leads to a working system.

Comment 7 Daniel Burgess 2022-04-28 15:26:17 UTC
Fedora Kinoite 36 has the same issue. Europe/London timezone. Trying to get my brother to switch from popOS after his install exploded after an update. Changing timezone fixes it but it's really not a solution.

Comment 8 Timothée Ravier 2022-05-15 14:24:57 UTC
Posted a patch upstream: https://invent.kde.org/frameworks/kservice/-/merge_requests/87

You can try the fix by downloading the RPM from https://koji.fedoraproject.org/koji/taskinfo?taskID=87087243 and then running:
```
$ rpm-ostree override replace ./kf5-kservice-5.93.0-2.fc36.x86_64.rpm
```
and reboot

Comment 9 Fedora Update System 2022-05-17 15:01:40 UTC
FEDORA-2022-5f52a69edb has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-5f52a69edb

Comment 10 Fedora Update System 2022-05-17 15:04:49 UTC
FEDORA-2022-5f52a69edb has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Danny Roberts 2022-05-23 15:19:24 UTC
Any chance of this being backported to Kinotie 36? Without this fix the only just released Kinoite 36 is effectively unusable in the UTC timezone.

Comment 12 Timothée Ravier 2022-05-23 15:59:06 UTC
This will come to Fedora 36 as part of the update to KDE Frameworks to 5.94 that should happen in the coming days/weeks.

Comment 13 Timothée Ravier 2022-05-23 15:59:45 UTC
Same for F35, if it ever gets this update (not sure about that though).

Comment 14 Timothée Ravier 2022-06-26 20:22:59 UTC
This is now in Kinoite 36 too.


Note You need to log in before you can comment on or make changes to this bug.