Bug 202122 - CVE-2006-3745 Local SCTP privilege escalation
CVE-2006-3745 Local SCTP privilege escalation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
urgent Severity high
: ---
: ---
Assigned To: Neil Horman
Brian Brock
impact=important,source=kernelsec,rep...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 16:57 EDT by Marcel Holtmann
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHSA-2006-0617
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 14:53:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Holtmann 2006-08-10 16:57:59 EDT
Report from Wei Wang of McAfee Avert Labs:

A locally exploitable flaw has been found in the Linux sctp module
sctp_make_abort_user function that allows local users to gain root privileges
and also execute arbitrary code at kernel privilege level.
Comment 11 Jason Baron 2006-08-18 10:04:44 EDT
committed in kernel 42.0.2
Comment 13 Red Hat Bugzilla 2006-08-22 14:53:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2006-0617.html
Comment 14 Jason Baron 2006-08-30 13:55:49 EDT
committed in stream U5 build 42.4. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/

Note You need to log in before you can comment on or make changes to this bug.