Red Hat Bugzilla – 2021247 – radiusd fails to start when mysql is installed - unterminated string in /etc/raddb/mods-config/sql/ippool/mysql/queries.conf line 117
Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
- radiusd service fails to start.
- Error is displayed in debugging mode.
# radiusd -X
[..]
/etc/raddb/mods-config/sql/ippool/mysql/queries.conf[117]: Parse error: Unterminated string
Line 117 is missing closing double quote (") - /etc/raddb/mods-config/sql/ippool/mysql/queries.conf
~~~
111 allocate_update = "\
112 UPDATE ${ippool_table} \
113 SET \
114 nasipaddress = '%{NAS-IP-Address}', pool_key = '${pool_key}', \
115 callingstationid = '%{Calling-Station-Id}', \
116 username = '%{User-Name}', expiry_time = NOW() + INTERVAL ${lease_duration} SECOND \
117 WHERE framedipaddress = '%I'
~~~
Version-Release number of selected component (if applicable):
freeradius-3.0.20-3.module+el8.3.0+7597+67902674.x86_64
freeradius-mysql-3.0.20-3.module+el8.3.0+7597+67902674.x86_64
How reproducible:
Fully
Steps to Reproduce:
1. Install packages
# dnf install freeradius freeradius-mysql mysql
2. Configure and start freeradius, mysql
3. Start FreeRADIUS
# radiusd -X
Actual results:
- Running FreeRADIUS in debugging mode.
[root@host ~]# radiusd -X
FreeRADIUS Version 3.0.20
Copyright (C) 1999-2019 The FreeRADIUS server project and contributors
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE
You may redistribute copies of FreeRADIUS under the terms of the
GNU General Public License
For more information about these matters, see the file named COPYRIGHT
Starting - reading configuration files ...
including dictionary file /usr/share/freeradius/dictionary
including dictionary file /usr/share/freeradius/dictionary.dhcp
including dictionary file /usr/share/freeradius/dictionary.vqp
including dictionary file /etc/raddb/dictionary
including configuration file /etc/raddb/radiusd.conf
including configuration file /etc/raddb/proxy.conf
including configuration file /etc/raddb/clients.conf
including files in directory /etc/raddb/mods-enabled/
including configuration file /etc/raddb/mods-enabled/always
including configuration file /etc/raddb/mods-enabled/attr_filter
including configuration file /etc/raddb/mods-enabled/cache_eap
including configuration file /etc/raddb/mods-enabled/chap
including configuration file /etc/raddb/mods-enabled/date
including configuration file /etc/raddb/mods-enabled/detail
including configuration file /etc/raddb/mods-enabled/detail.log
including configuration file /etc/raddb/mods-enabled/digest
including configuration file /etc/raddb/mods-enabled/dynamic_clients
including configuration file /etc/raddb/mods-enabled/eap
including configuration file /etc/raddb/mods-enabled/echo
including configuration file /etc/raddb/mods-enabled/exec
including configuration file /etc/raddb/mods-enabled/expiration
including configuration file /etc/raddb/mods-enabled/expr
including configuration file /etc/raddb/mods-enabled/files
including configuration file /etc/raddb/mods-enabled/linelog
including configuration file /etc/raddb/mods-enabled/logintime
including configuration file /etc/raddb/mods-enabled/mschap
including configuration file /etc/raddb/mods-enabled/ntlm_auth
including configuration file /etc/raddb/mods-enabled/pap
including configuration file /etc/raddb/mods-enabled/passwd
including configuration file /etc/raddb/mods-enabled/preprocess
including configuration file /etc/raddb/mods-enabled/radutmp
including configuration file /etc/raddb/mods-enabled/realm
including configuration file /etc/raddb/mods-enabled/replicate
including configuration file /etc/raddb/mods-enabled/soh
including configuration file /etc/raddb/mods-enabled/sradutmp
including configuration file /etc/raddb/mods-enabled/unix
including configuration file /etc/raddb/mods-enabled/unpack
including configuration file /etc/raddb/mods-enabled/utf8
including configuration file /etc/raddb/mods-enabled/sql
including configuration file /etc/raddb/mods-config/sql/main/mysql/queries.conf
including configuration file /etc/raddb/mods-enabled/sqlippool
including configuration file /etc/raddb/mods-config/sql/ippool/mysql/queries.conf
/etc/raddb/mods-config/sql/ippool/mysql/queries.conf[117]: Parse error: Unterminated string
Expected results:
- radiusd should start without parsing error.
Additional info:
- Upstream fix already in place.
Add " to Line 143
(https://github.com/FreeRADIUS/freeradius-server/commit/81d001e04d7c850fba8ab9117f0039b3b2f4fe23)
- Fix for this issue is required in RHEL 8.4.
Comment 5Theodoros Apazoglou
2021-11-17 12:10:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (freeradius:3.0 bug fix and enhancement update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2022:1868
Description of problem: - radiusd service fails to start. - Error is displayed in debugging mode. # radiusd -X [..] /etc/raddb/mods-config/sql/ippool/mysql/queries.conf[117]: Parse error: Unterminated string Line 117 is missing closing double quote (") - /etc/raddb/mods-config/sql/ippool/mysql/queries.conf ~~~ 111 allocate_update = "\ 112 UPDATE ${ippool_table} \ 113 SET \ 114 nasipaddress = '%{NAS-IP-Address}', pool_key = '${pool_key}', \ 115 callingstationid = '%{Calling-Station-Id}', \ 116 username = '%{User-Name}', expiry_time = NOW() + INTERVAL ${lease_duration} SECOND \ 117 WHERE framedipaddress = '%I' ~~~ Version-Release number of selected component (if applicable): freeradius-3.0.20-3.module+el8.3.0+7597+67902674.x86_64 freeradius-mysql-3.0.20-3.module+el8.3.0+7597+67902674.x86_64 How reproducible: Fully Steps to Reproduce: 1. Install packages # dnf install freeradius freeradius-mysql mysql 2. Configure and start freeradius, mysql 3. Start FreeRADIUS # radiusd -X Actual results: - Running FreeRADIUS in debugging mode. [root@host ~]# radiusd -X FreeRADIUS Version 3.0.20 Copyright (C) 1999-2019 The FreeRADIUS server project and contributors There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE You may redistribute copies of FreeRADIUS under the terms of the GNU General Public License For more information about these matters, see the file named COPYRIGHT Starting - reading configuration files ... including dictionary file /usr/share/freeradius/dictionary including dictionary file /usr/share/freeradius/dictionary.dhcp including dictionary file /usr/share/freeradius/dictionary.vqp including dictionary file /etc/raddb/dictionary including configuration file /etc/raddb/radiusd.conf including configuration file /etc/raddb/proxy.conf including configuration file /etc/raddb/clients.conf including files in directory /etc/raddb/mods-enabled/ including configuration file /etc/raddb/mods-enabled/always including configuration file /etc/raddb/mods-enabled/attr_filter including configuration file /etc/raddb/mods-enabled/cache_eap including configuration file /etc/raddb/mods-enabled/chap including configuration file /etc/raddb/mods-enabled/date including configuration file /etc/raddb/mods-enabled/detail including configuration file /etc/raddb/mods-enabled/detail.log including configuration file /etc/raddb/mods-enabled/digest including configuration file /etc/raddb/mods-enabled/dynamic_clients including configuration file /etc/raddb/mods-enabled/eap including configuration file /etc/raddb/mods-enabled/echo including configuration file /etc/raddb/mods-enabled/exec including configuration file /etc/raddb/mods-enabled/expiration including configuration file /etc/raddb/mods-enabled/expr including configuration file /etc/raddb/mods-enabled/files including configuration file /etc/raddb/mods-enabled/linelog including configuration file /etc/raddb/mods-enabled/logintime including configuration file /etc/raddb/mods-enabled/mschap including configuration file /etc/raddb/mods-enabled/ntlm_auth including configuration file /etc/raddb/mods-enabled/pap including configuration file /etc/raddb/mods-enabled/passwd including configuration file /etc/raddb/mods-enabled/preprocess including configuration file /etc/raddb/mods-enabled/radutmp including configuration file /etc/raddb/mods-enabled/realm including configuration file /etc/raddb/mods-enabled/replicate including configuration file /etc/raddb/mods-enabled/soh including configuration file /etc/raddb/mods-enabled/sradutmp including configuration file /etc/raddb/mods-enabled/unix including configuration file /etc/raddb/mods-enabled/unpack including configuration file /etc/raddb/mods-enabled/utf8 including configuration file /etc/raddb/mods-enabled/sql including configuration file /etc/raddb/mods-config/sql/main/mysql/queries.conf including configuration file /etc/raddb/mods-enabled/sqlippool including configuration file /etc/raddb/mods-config/sql/ippool/mysql/queries.conf /etc/raddb/mods-config/sql/ippool/mysql/queries.conf[117]: Parse error: Unterminated string Expected results: - radiusd should start without parsing error. Additional info: - Upstream fix already in place. Add " to Line 143 (https://github.com/FreeRADIUS/freeradius-server/commit/81d001e04d7c850fba8ab9117f0039b3b2f4fe23) - Fix for this issue is required in RHEL 8.4.