Bug 202146 - locking problem stacktrace in messages file (slock-AF_INET6)
locking problem stacktrace in messages file (slock-AF_INET6)
Status: CLOSED DUPLICATE of bug 205487
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_LOCKDEP
  Show dependency treegraph
 
Reported: 2006-08-10 21:29 EDT by Olen
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 19:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olen 2006-08-10 21:29:18 EDT
Description of problem:
This message is in my /var/log/messages file:
Aug 10 19:58:31 blackboxofdeath kernel: 
Aug 10 19:58:31 blackboxofdeath kernel:
=============================================
Aug 10 19:58:31 blackboxofdeath kernel: [ INFO: possible recursive locking
detected ]
Aug 10 19:58:31 blackboxofdeath kernel:
---------------------------------------------
Aug 10 19:58:31 blackboxofdeath kernel: setxkbmap/2402 is trying to acquire lock:
Aug 10 19:58:31 blackboxofdeath kernel:  (slock-AF_INET6){-+..}, at:
[<c05ab7e9>] sk_clone+0xb6/0x2bd
Aug 10 19:58:31 blackboxofdeath kernel: 
Aug 10 19:58:31 blackboxofdeath kernel: but task is already holding lock:
Aug 10 19:58:31 blackboxofdeath kernel:  (slock-AF_INET6){-+..}, at:
[<e0bd8ed9>] tcp_v6_rcv+0x327/0x736 [ipv6]
Aug 10 19:58:31 blackboxofdeath kernel: 
Aug 10 19:58:31 blackboxofdeath kernel: other info that might help us debug this:
Aug 10 19:58:31 blackboxofdeath kernel: 1 lock held by setxkbmap/2402:
Aug 10 19:58:31 blackboxofdeath kernel:  #0:  (slock-AF_INET6){-+..}, at:
[<e0bd8ed9>] tcp_v6_rcv+0x327/0x736 [ip
v6]
Aug 10 19:58:31 blackboxofdeath kernel: 
Aug 10 19:58:32 blackboxofdeath kernel: stack backtrace:
Aug 10 19:58:32 blackboxofdeath kernel:  [<c04051ee>] show_trace_log_lvl+0x58/0x159
Aug 10 19:58:32 blackboxofdeath kernel:  [<c04057ea>] show_trace+0xd/0x10
Aug 10 19:58:32 blackboxofdeath kernel:  [<c0405903>] dump_stack+0x19/0x1b
Aug 10 19:58:32 blackboxofdeath kernel:  [<c043b846>] __lock_acquire+0x773/0x997
Aug 10 19:58:32 blackboxofdeath kernel:  [<c043bfdb>] lock_acquire+0x4b/0x6c
Aug 10 19:58:32 blackboxofdeath kernel:  [<c0608c23>] _spin_lock+0x19/0x28
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05ab7e9>] sk_clone+0xb6/0x2bd
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05d30f6>] inet_csk_clone+0xd/0x5e
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05e3e09>]
tcp_create_openreq_child+0x1b/0x3a1
Aug 10 19:58:32 blackboxofdeath kernel:  [<e0bd7bba>]
tcp_v6_syn_recv_sock+0x248/0x584 [ipv6]
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05e4344>] tcp_check_req+0x1b5/0x2c9
Aug 10 19:58:32 blackboxofdeath kernel:  [<e0bd6ec7>] tcp_v6_do_rcv+0x142/0x340
[ipv6]
Aug 10 19:58:32 blackboxofdeath kernel:  [<e0bd9293>] tcp_v6_rcv+0x6e1/0x736 [ipv6]
Aug 10 19:58:32 blackboxofdeath kernel:  [<e0bbfa23>] ip6_input+0x1c3/0x296 [ipv6]
Aug 10 19:58:32 blackboxofdeath kernel:  [<e0bbff93>] ipv6_rcv+0x1d2/0x21f [ipv6]
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05b1874>] netif_receive_skb+0x204/0x271
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05b31d7>] process_backlog+0x99/0xfa
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05b33ba>] net_rx_action+0x9d/0x196
Aug 10 19:58:32 blackboxofdeath kernel:  [<c04293c7>] __do_softirq+0x78/0xf2
Aug 10 19:58:32 blackboxofdeath kernel:  [<c0406673>] do_softirq+0x5a/0xbe
Aug 10 19:58:32 blackboxofdeath kernel:  [<c04291be>] local_bh_enable_ip+0xa9/0xcf
Aug 10 19:58:32 blackboxofdeath kernel:  [<c0608bc1>] _spin_unlock_bh+0x25/0x28
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05aa607>] release_sock+0xb0/0xb8
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05ebf8a>]
inet_stream_connect+0x113/0x206
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05a956a>] sys_connect+0x67/0x84
Aug 10 19:58:32 blackboxofdeath kernel:  [<c05a9bdc>] sys_socketcall+0x8c/0x186
Aug 10 19:58:32 blackboxofdeath kernel:  [<c0403faf>] syscall_call+0x7/0xb
Aug 10 19:58:32 blackboxofdeath kernel: DWARF2 unwinder stuck at
syscall_call+0x7/0xb
Aug 10 19:58:32 blackboxofdeath kernel: Leftover inexact backtrace:


Version-Release number of selected component (if applicable):
Name        : kernel                       Relocations: (not relocatable)
Version     : 2.6.17                            Vendor: Red Hat, Inc.
Release     : 1.2517.fc6                    Build Date: Thu 03 Aug 2006 05:17:38
AM CDT


How reproducible:
3rd day using this kernel, 2panic starting up, and this back trace in my messages.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Just reporting this, in case it helps find a kernel problem.
Comment 1 Dave Jones 2006-08-11 01:42:53 EDT
This should be fixed in the current rawhide kernel, can you update and confirm?
Comment 2 Olen 2006-08-19 10:17:53 EDT
My power supply was failing, so not sure this was ever a valid problem report.
I did try the new kernel, and haven't seen this anymore.
I would suggest closing this bug too.
Comment 3 Dave Jones 2006-10-04 19:38:33 EDT

*** This bug has been marked as a duplicate of 205487 ***

Note You need to log in before you can comment on or make changes to this bug.