Bug 202182 - Link veth0 is missing with kernel-xen-2174
Link veth0 is missing with kernel-xen-2174
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brian Brock
:
: 201796 (view as bug list)
Depends On:
Blocks: 179599
  Show dependency treegraph
 
Reported: 2006-08-11 08:57 EDT by Thomas Hutterer
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 16:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hutterer 2006-08-11 08:57:23 EDT
Description of problem:
I am using kernel-xen-2174 on my host and kernel-xen-2174 in my guest. 
If a start xend it does not create the bridge device

With kernel-xen0-2174 and kernel-xenU-2174 everything works proberly

Version-Release number of selected component (if applicable):
xen 3.0.2
kernel-xen-2174


How reproducible:
install kernel-xen-2174 and start xend


Steps to Reproduce:
1. install kernel-xen-2174
2. boot
3. /etc/init.d/xend start
  
Actual results:
xend-debug shows: 

Link veth0 is missing.
This may be because you have reached the limit of the number of interfaces
that the loopback driver supports.  If the loopback driver is a module, you
may raise this limit by passing it as a parameter (nloopbacks=<N>); if the
driver is compiled statically into the kernel, then you may set the parameter
using loopback.nloopbacks=<N> on the domain 0 kernel command line.


Expected results:
available Network

Additional info:
Comment 1 Herbert Xu 2006-08-11 09:06:14 EDT
Could you please show me the result of

ifconfig
lsmod

Thanks,
Comment 2 Thomas Hutterer 2006-08-11 09:14:06 EDT
Results of ifconfig: 

eth0      Link encap:Ethernet  HWaddr 00:11:43:DA:CE:4D  
          inet addr:62.218.34.138  Bcast:62.218.34.143  Mask:255.255.255.240
          inet6 addr: fe80::211:43ff:feda:ce4d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:84 errors:0 dropped:0 overruns:0 frame:0
          TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:8479 (8.2 KiB)  TX bytes:9191 (8.9 KiB)
          Base address:0xecc0 Memory:dfbe0000-dfc00000 

eth1      Link encap:Ethernet  HWaddr 00:11:43:DA:CE:4E  
          inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::211:43ff:feda:ce4e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:325118 errors:0 dropped:0 overruns:0 frame:0
          TX packets:149492 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:458690930 (437.4 MiB)  TX bytes:19657794 (18.7 MiB)
          Base address:0xdcc0 Memory:df9e0000-dfa00000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)




Results of lsmod: 

Module                  Size  Used by
drbd                  139092  3 
ipv6                  246497  18 
autofs4                24773  1 
ip_conntrack_netbios_ns     7105  0 
ipt_REJECT              9281  1 
xt_state                6209  2 
ip_conntrack           54177  2 ip_conntrack_netbios_ns,xt_state
nfnetlink              10841  1 ip_conntrack
xt_tcpudp               7233  4 
iptable_filter          7105  1 
ip_tables              17157  1 iptable_filter
x_tables               18117  4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables
loop                   19273  0 
dm_mirror              25361  0 
dm_multipath           23113  0 
dm_mod                 58841  2 dm_mirror,dm_multipath
video                  19525  0 
button                 10705  0 
battery                13381  0 
ac                      8901  0 
lp                     16393  0 
parport_pc             29669  0 
parport                38409  2 lp,parport_pc
sg                     36445  0 
e1000                 110137  0 
hw_random               9817  0 
serio_raw              11077  0 
e752x_edac             14405  0 
edac_mc                17925  1 e752x_edac
ext3                  125641  2 
jbd                    57813  1 ext3
megaraid_mbox          35921  6 
megaraid_mm            15213  1 megaraid_mbox
sd_mod                 22977  7 
scsi_mod              132073  3 sg,megaraid_mbox,sd_mod


If I don't use DRBD I get the same error


Greetings

Comment 3 Herbert Xu 2006-08-11 09:40:23 EDT
Please try

modprobe blkbk
modprobe netbk
modprobe netloop

before you start xend

Please also make sure that you have the latest version of the package containing
xend itself.
Comment 4 Thomas Hutterer 2006-08-11 10:09:07 EDT
my xen package is xen-3.0.2-3.FC5

executing the three modprobes lets xend create the bridge device. But if I now
start my guest I get the following output: 

Going to boot Fedora Core (2.6.17-1.2174_FC5xen)
  kernel: /boot/vmlinuz-2.6.17-1.2174_FC5xen
  initrd: /boot/initrd-2.6.17-1.2174_FC5xen.img
Started domain cms1
Linux version 2.6.17-1.2174_FC5xen (brewbuilder@hs20-bc2-3.build.redhat.com)
(gcc version 4.1.1 20060525 (Red Hat 4.1.1-1)) #1 SMP Tue Aug 8 16:34:15 EDT 2006
BIOS-provided physical RAM map:
 Xen: 0000000000000000 - 000000005e400000 (usable)
780MB HIGHMEM available.
727MB LOWMEM available.
NX (Execute Disable) protection: active
ACPI in unprivileged domain disabled
Built 1 zonelists
Kernel command line:  ro root=LABEL=/
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 16384 bytes)
Xen reported: 2992.692 MHz processor.
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Software IO TLB disabled
vmalloc area: ee000000-f4ffe000, maxmem 2d7fe000
Memory: 1513336k/1544192k available (2091k kernel code, 21448k reserved, 840k
data, 172k init, 798728k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 7486.03 BogoMIPS (lpj=14972067)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 512
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 1024K
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 16k freed
Brought up 1 CPUs
checking if image is initramfs... it is
Freeing initrd memory: 1971k freed
Grant table initialized
NET: Registered protocol family 16
Brought up 1 CPUs
PCI: setting up Xen PCI frontend stub
ACPI: Subsystem revision 20060127
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI: disabled
xen_mem: Initialising balloon driver.
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: System does not support PCI
PCI: System does not support PCI
NET: Registered protocol family 2
IP route cache hash table entries: 65536 (order: 6, 262144 bytes)
TCP established hash table entries: 131072 (order: 9, 2621440 bytes)
TCP bind hash table entries: 65536 (order: 8, 1310720 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
IA-32 Microcode Update Driver: v1.14-xen <tigran@veritas.com>
audit: initializing netlink socket (disabled)
audit(1155305927.974:1): initialized
highmem bounce pool size: 64 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 159031EDF350496D
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
rtc: IRQ 8 is not free.
Non-volatile memory driver v1.2
Linux agpgart interface v0.101 (c) Dave Jones
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Xen virtual console successfully installed as tty1
Event-channel device installed.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
ide-floppy driver 0.99.newide
usbcore: registered new driver libusual
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
PNP: No PS/2 controller found. Probing ports directly.
i8042.c: No controller found.
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI No-Shortcut mode
XENBUS: Device with no driver: device/vbd/51712
XENBUS: Device with no driver: device/vif/0
Freeing unused kernel memory: 172k freed
Red Hat nash version 5.0.32 starting
Mounting proc filesystem
Mounting sysfs filesystem
Creating /dev
Creating initial device nodes
Setting up hotplug.
Creating block device nodes.
Loading jbd.ko module
Loading ext3.ko module
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!



/var/log/xend-debug.log: 
ERROR: Non PAE-kernel on PAE host.
ERROR: Error constructing guest OS


Why comes this error message? I thougt, kernel-xen has PAE enabled?



I have created this guest with FC5 and kernel-xen0. In the guest was kernel-xenU
installed. After the successfull installation I installed kernel-xen-2174 (the
one with PAE) on the guest and on the host. 


Greetings
Comment 5 Jeremy Katz 2006-08-14 15:42:37 EDT
If you're using kernel-xen in the guest, you also need 'alias scsi_hostadapter
xenblk' in /etc/modprobe.conf of the guest before installing the kernel so the
initrd ends up with the needed driver.
Comment 6 Herbert Xu 2006-08-14 19:01:10 EDT
Hi Jeremy:

Could you please check whether we have these modprobe's in the init.d script and
add them if necessary?  Thanks.
Comment 7 Jeremy Katz 2006-08-14 20:49:39 EDT
They're in the initscript of the current xen package, but I don't know that
we've pushed back all the stuff from rawhide to FC5 at this point because doing
so requires quite a bit of coordination (to get kernel + userspace all done at
the same time)
Comment 8 Herbert Xu 2006-08-15 06:14:49 EDT
*** Bug 201796 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Hutterer 2006-08-16 06:45:45 EDT
Hi! 

To load the neccesary modules,I have inserted the following commands in
/etc/init.d/xend on the host  
case "$1" in
  start)
        echo -n $"Starting $prog: "
        modprobe blkbk
        modprobe netbk
        modprobe netloop


And I have added following line in /etc/modprobe.conf in the guest: 
alias scsi_hostadapter xenblk


Now the guest starts without any problems. 

thx for the help,
    Thomas



Note You need to log in before you can comment on or make changes to this bug.