Bug 202222 - gnome-screensaver fails to activate
Summary: gnome-screensaver fails to activate
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
(Show other bugs)
Version: 5
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-11 17:12 UTC by Mark
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 13:55:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results of commands (1.06 KB, text/plain)
2006-08-14 12:22 UTC, Mark
no flags Details

Description Mark 2006-08-11 17:12:02 UTC
Description of problem: gnome-screensaver fails to activate. I had xscreensaver
installed and it worked correctly. I uninstalled xscreensaver. gnome-screensaver
does not activate. If I try gnome-screensaver-command on the command line I get
a dbus error, failed to connect to socket. (I also get this error when I enter
dbus-monitor on the command line). I tried re-installing xscreensaver and it
also no longer works. I tried re-installing gnome-screensaver and the dbus
components with no improvement. I have not tried re-installing gnome-session.

I also noticed that the screensaver preferences application does not get
correctly updated on the menus.

I would be willing to fix the problem by manually editting configuration files,
etc, but as yet I have been unable to determine how the screen saver daemons are
started and mechanism used by the system to determine which screen saver to
activate.

Version-Release number of selected component (if applicable):
2.14.2-1

How reproducible:
Always

Steps to Reproduce:
1. See description
2.
3.
  
Actual results:
Screen saver activates.

Expected results:


Additional info:

Comment 1 Ray Strode [halfline] 2006-08-11 17:32:41 UTC
do you use gdm or "startx" ?

what is the output of 

echo $DBUS_SESSION_BUS_ADDRESS

?

Comment 2 Mark 2006-08-14 12:22:40 UTC
Created attachment 134133 [details]
Results of commands

I am using gdm.

The attached file contains the results of 

echo $DBUS_SESSION_BUS_ADDRESS
ps -ef | grep dbus
gnome-screensaver-command
dbus-monitor

Comment 3 Ray Strode [halfline] 2006-08-14 13:12:26 UTC
are you running a custom kernel without abstract sockets support?

Comment 4 Mark 2006-08-14 15:00:31 UTC
No. I currently have kernel-2.6.17-1.2157_FC5.x86_64.rpm installed.

Comment 5 Ray Strode [halfline] 2006-08-14 15:08:59 UTC
what is the output of /usr/sbin/getenforce ?

Comment 6 Mark 2006-08-15 12:58:51 UTC
Enforcing

I also tried Permissive just for fun. No changes in response.

Comment 7 Ray Strode [halfline] 2006-08-15 16:24:12 UTC
Well this is clearly some sort of d-bus issue.  John, do you have any ideas?

Comment 8 John (J5) Palmieri 2006-08-15 17:24:23 UTC
Different version of D-Bus installed on his system.  Either from source or a
failed upgrade and clean.  Check to see if you have a dbus-daemon in /usr/bin.

Comment 9 Mark 2006-08-16 12:01:17 UTC
Yes. There was a /usr/bin/dbus-daemon and /usr/bin/dbus-cleanup-sockets. Once I
removed them, logged out and back in, gnome-screensaver worked as expected.

Here is what I think had happened. I upgraded this system from FC4 to FC5
shortly after FC5 was released. Apparently those two files did not get cleaned
up  with the dbus upgrade. But I did not notice a problem because I was using
xscreensaver. The problem became apparent when I removed xscreensaver a couple
of weeks ago. It is still a mystery to me why xscreensaver did not work when I
re-installed it.

Comment 10 Ray Strode [halfline] 2006-08-16 13:55:17 UTC
Hi John,

Thanks for help. I'm going to close the bug, Mark, since it seems like it may
have been a one off problem.


Note You need to log in before you can comment on or make changes to this bug.