Bug 2022354 - Network gateway stays out-of-sync after upgrade
Summary: Network gateway stays out-of-sync after upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.40.80
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.4.10
: 4.40.100.1
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-11 12:40 UTC by Ales Musil
Modified: 2022-01-19 07:00 UTC (History)
3 users (show)

Fixed In Version: vdsm-4.40.100.1-1.el8ev.x86_64
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-19 07:00:13 UTC
oVirt Team: Network
mperina: ovirt-4.4+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHV-43962 0 None None None 2021-11-11 12:45:26 UTC
Red Hat Knowledge Base (Solution) 2950771 0 None None None 2021-12-23 18:04:55 UTC
oVirt gerrit 117588 0 master MERGED net: Fix source route definition when missing 2021-11-15 12:43:19 UTC
oVirt gerrit 117627 0 ovirt-4.4.z MERGED net: Fix source route definition when missing 2021-11-15 13:33:38 UTC

Description Ales Musil 2021-11-11 12:40:36 UTC
Description of problem:
After update to use nmstate source routes the code won't create 
a new source route unless the config has changed. This however might not be 
the case if the routes for example removed externally, in that case
the network configuration would stay the same but the route is missing. 
That causes out-of-sync on engine that cannot be fixed by simple network synchronization. 

Version-Release number of selected component (if applicable):
vdsm-4.40.80.6-1.el8ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Setup network with custom gateway (static/dynamic) that is not default route
2. Remove the source route from host 
3. try to synchronize the network on the host


Actual results:
Engine shows the network is still out-of-sync, missing the gateway

Expected results:
It should be synchronized

Additional info:
There are two possible workarounds:
1) Change or remove the gateway of affected network, apply the configuration to the host and then apply the configuration again with the gateway back. 
2) Remove /var/lib/vdsm/staging/netconf/nets/$NET_NAME on the host and then run network synchronization from engine

Comment 1 Ales Musil 2021-11-11 13:21:36 UTC
One small thing to note, this does not apply to networks that have default route role.

Comment 3 Michael Burman 2021-11-22 12:35:32 UTC
Verified on - vdsm-4.40.100.1-1.el8ev.x86_64 with rhvm-4.4.10-0.17.el8ev.noarch

Comment 4 Sandro Bonazzola 2022-01-19 07:00:13 UTC
This bugzilla is included in oVirt 4.4.10 release, published on January 18th 2022.

Since the problem described in this bug report should be resolved in oVirt 4.4.10 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.