Bug 2022385 - Replace the fbdev drivers with simpledrm and the DRM fbdev emulation layer
Summary: Replace the fbdev drivers with simpledrm and the DRM fbdev emulation layer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Javier Martinez Canillas
QA Contact:
URL:
Whiteboard:
: 1986222 (view as bug list)
Depends On: 2067151
Blocks: ARMTracker IoT WaylandRelated KDEWaylandRelated F36Changes
TreeView+ depends on / blocked
 
Reported: 2021-11-11 14:33 UTC by Ben Cotton
Modified: 2022-05-10 14:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-10 14:41:45 UTC
Type: ---


Attachments (Terms of Use)

Description Ben Cotton 2021-11-11 14:33:25 UTC
This is a tracking bug for Change: Replace the fbdev drivers with simpledrm and the DRM fbdev emulation layer
For more details, see: https://fedoraproject.org/wiki/Changes/ReplaceFbdevDrivers

This change replaces the legacy Linux frame buffer device (fbdev) drivers that are still used in Fedora, with the latest simpledrm driver and the DRM fbdev emulation layer.

If you encounter a bug related to this Change, please do not comment here. Instead create a new bug and set it to block this bug.

Comment 1 Javier Martinez Canillas 2021-12-23 11:26:38 UTC
This change has been present in the Fedora kernel since https://gitlab.com/cki-project/kernel-ark/-/commit/53d2c01aef5aaad8b8bb54e4254f6ae671c76ee5

Comment 2 Javier Martinez Canillas 2021-12-23 11:44:17 UTC
*** Bug 1986222 has been marked as a duplicate of this bug. ***

Comment 3 Ben Cotton 2022-02-08 21:06:33 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 36 development cycle.
Changing version to 36.

Comment 4 Ben Cotton 2022-02-22 16:34:36 UTC
We have reached the 'Change complete (100% complete)' deadline in the Fedora Linux 36 release schedule.

At this time, all Changes should be fully complete. Indicate this by setting this tracking bug to ON_QA.

If you need to defer this Change to a subsequent release, please needinfo me.

Comment 5 Ben Cotton 2022-05-10 14:41:45 UTC
F36 was released today. If this Change did not land in the release, please notify bcotton as soon as possible.


Note You need to log in before you can comment on or make changes to this bug.